1998 M3 Alarm issues


Thread: 1998 M3 Alarm issues

Reply to Thread
Results 1 to 2 of 2
  1. 1998 M3 Alarm issues 
    Bimmer Fan
    Car Details
    M3_Saloon's Car Details
    Model of Car:
    Year of Manufacture:
    Transmission Type:
    Car Body Type:

    Join Date
    May 2012
    Thanked 0 Times in 0 Posts
    Hi guys this is my first post on here, the knowledge on here seems fantastic and after carrying out some searches online the best advice seems to come from this forum although i could'nt find exactly what i'm after.

    I have a 1998 E36 M3 and after having some paint work carried out on the car the factory alarm is playing up.

    It has the radio remote control and i believe EWSII?

    I have read the guides on here and checked bootlid wiring, found some fractured wires, repaired them but still the problem persists.

    Whats happening is that the alarm seems to set correctly, the hazards flash once, the central locking acivates and all seems well. However the alarm goes off sometimes after 15 mins other times after 3 hours.

    When i set the alarm the telltale light flashes rapidly for about 10 secs then flashes every second or so as expected. Is the rapid flashing a sign / warning of an issue? I cannot recall ever taking any notice of the telltale lights when activating it before so do not know what is 'normal'

    I have tried cable tieing the boot and bonnet sensors down to simulate them being closed incase one of these was not 'making' properly but still no cure.

    I have charged the battery incase a slight loss in voltage may affect it but again still happened.

    Any help or advice woulds be greatly appreciated. I'm due to drive the car to the south of france in three weeks and its driving me crazy.

    On a side note, the car does not appear to have motion sensors in the car. What is actually connected to the alarm? 4 doors and bonnet boot? do the windows have anything on them to note position?

    I'm not great with electrics but competant enough and have a clamp / probe so can carry out some checks if directed

    Thanks in advance.


  2. Remove Advertisements

    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    Transmission Type:
    Car Body Type:
    edber's Avatar
    Join Date
    Mar 2012
    South ireland
    Thanked 672 Times in 629 Posts
    hi m3,yes i think i read somewhere that the rapid telltale flashing is a sign that somethings not rite.it cud just be a faulty door switch or bonnet or boot switch thats not contacting correctly then after a while the car sees this as an intrusion attempt and sets of the alarm.maybe try clearing the errors with inpa or other soft/hardware to see if that clears it or try disconnecting the battery overnight to reset the ecu.

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts