1998 E36 318ti - service indicator wont reset

Notices
 

Thread: 1998 E36 318ti - service indicator wont reset

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. 1998 E36 318ti - service indicator wont reset 
    #1
    Bimmer Fan
    Car Details
    dusty605's Car Details
    Model of Car:
    318ti
    Year of Manufacture:
    1998
    Transmission Type:
    auto
    Car Body Type:
    hatch

    Join Date
    May 2010
    Location
    oxfordshire
    Posts
    6
    Thanks
    0
    Thanked 2 Times in 1 Post
    hi there just joined the forum after reading various threads before. i have found alot of stuff about how to reset the service lights on my 1998 318ti but cant see anything on what to do if they wont reset. i have had the car since feb this year and the orange light was on, so service due. i carried out the service myself and tried resetting the lights but they didnt, no matter how many times i tried or which method i used. the orange light is still on which i find is strange because it should have surely hit the red by now after 4 mths of having it. any ideas please. thanx, dusty.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Crazed
    Car Details
    ako89's Car Details
    Model of Car:
    318i SE
    Year of Manufacture:
    1993
    Transmission Type:
    Manual Obv!
    Car Body Type:
    Saloon
    ako89's Avatar
    Join Date
    Jan 2010
    Location
    Crewe, Cheshire, UK
    Posts
    241
    Thanks
    21
    Thanked 42 Times in 41 Posts
    What was the main method you tried?
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    dusty605's Car Details
    Model of Car:
    318ti
    Year of Manufacture:
    1998
    Transmission Type:
    auto
    Car Body Type:
    hatch

    Join Date
    May 2010
    Location
    oxfordshire
    Posts
    6
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by ako89 View Post
    What was the main method you tried?
    i tried the paperclip method between the 2 pins whos numbers escape me and i also tried using an led test lamp between the one pin and earth, neither did anything at all.i know all leds work because when i first turn the ignition on they all light up.
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    dusty605's Car Details
    Model of Car:
    318ti
    Year of Manufacture:
    1998
    Transmission Type:
    auto
    Car Body Type:
    hatch

    Join Date
    May 2010
    Location
    oxfordshire
    Posts
    6
    Thanks
    0
    Thanked 2 Times in 1 Post
    i am guessing that not many of you have come across this problem before.
     
     

  7.  
    #5
    BMW Fanatic
    Car Details
    civicdan's Car Details
    Model of Car:
    316i
    Year of Manufacture:
    1997
    Transmission Type:
    manual
    Car Body Type:
    compact
    civicdan's Avatar
    Join Date
    Apr 2010
    Location
    mansfield
    Posts
    67
    Thanks
    1
    Thanked 1 Time in 1 Post
    i tried it on my car mate and took around 6 attempts with paper clip. I had to clean up holes with paper clip a bit before worked and i read to hold for 4 seconds but worked for me around 7 seconds hope this helps
     
     

  8.  
    #6
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    Quote Originally Posted by dusty605 View Post
    i tried the paperclip method between the 2 pins whos numbers escape me and i also tried using an led test lamp between the one pin and earth, neither did anything at all.i know all leds work because when i first turn the ignition on they all light up.
    don't use a LED test lamp, connect the pin straight to ground or just pick up a draper tool of ebay there always under £15 delivered and well worth it. Stops you frying your ECU by mistake.

    My tool took me two attempts and I had to do it with the ignition on
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    dusty605's Car Details
    Model of Car:
    318ti
    Year of Manufacture:
    1998
    Transmission Type:
    auto
    Car Body Type:
    hatch

    Join Date
    May 2010
    Location
    oxfordshire
    Posts
    6
    Thanks
    0
    Thanked 2 Times in 1 Post
    i have probably tried somewhere close to 15 - 20 times so far and just leaving it in for about 30 secs sometimes just to see if anything happens but nothing does. i thought about buying the draper tool for it but thought it was probably something more serious than this, especially since the service indicator hasnt dropped any lights since i bought it.
     
     

  10.  
    #8
    BMW Crazed
    Car Details
    carbers911's Car Details
    Model of Car:
    318iS
    Year of Manufacture:
    1996
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jan 2009
    Location
    York
    Posts
    157
    Thanks
    8
    Thanked 39 Times in 31 Posts
    Have you put the cap back on the diag connector after removing the clip but BEFORE switching off the ign?
    I had issues on mine and that solved them
     
     

  11.  
    #9
    Bimmer Fan
    Car Details
    dusty605's Car Details
    Model of Car:
    318ti
    Year of Manufacture:
    1998
    Transmission Type:
    auto
    Car Body Type:
    hatch

    Join Date
    May 2010
    Location
    oxfordshire
    Posts
    6
    Thanks
    0
    Thanked 2 Times in 1 Post
    havent tried that will give that one a go, thanx.
     
     

  12.  
    #10
    Platinum BFuk Member
    Car Details
    johnny-c2's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2002
    Transmission Type:
    auto
    Car Body Type:
    convertible
    johnny-c2's Avatar
    Join Date
    Mar 2010
    Location
    Burnley, Greater Lancashire!
    Posts
    264
    Thanks
    870
    Thanked 378 Times in 237 Posts
    is it oil service or inspection service?? i have attached some info for thee hope it helps!
    Attached Images
    Thanks button is here
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts