1997 M3 Evo engine into 1996 Compact: No spark - suggestions or advise please??

Notices
 

Thread: 1997 M3 Evo engine into 1996 Compact: No spark - suggestions or advise please??

Reply to Thread
Results 1 to 8 of 8
  1. 1997 M3 Evo engine into 1996 Compact: No spark - suggestions or advise please?? 
    #1
    BMW Fanatic
    Car Details
    Willem's Car Details
    Model of Car:
    M3 Evolution - now sold
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Aug 2009
    Location
    London
    Posts
    80
    Thanks
    14
    Thanked 30 Times in 13 Posts
    Need help please guys - I've installed a 1997 M3 Evo engine into a 1996 Compact with everything from the donor car - engine wiring harness, EWS, evn the ignition and door locks, etc etc.

    The project has progressed to a point where it should run but I have no spark.

    The key turns the engine ok and the central locking works with the key fob. From what I can find on the web is that if the starter engages then the EWS is ok. Its the interface with the DME that I'm not sure about. I understand a single wire sends the ISN to the DME.

    Does anyone know if the starting circuit is seperate from the DME's injection and fueling circuit? Will the engine turn without the DME activated?

    Any suggestions or thoughts please on where I should start??

    How good are the eBay diagnostic tools selling for £75 ish?


    Thanks for your help!!
    Last edited by Willem; 08-02-2010 at 19:06.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Did you change the DME over as well? The DME stores codes in a table that the EWS has to match up with before turning the ignition process on. I think that is where your problem lies.
     
     

  4.  
    #3
    BMW Fanatic
    Car Details
    Willem's Car Details
    Model of Car:
    M3 Evolution - now sold
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Aug 2009
    Location
    London
    Posts
    80
    Thanks
    14
    Thanked 30 Times in 13 Posts
    yes mate, did change the DME
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bfuk Legend
    Car Details
    RJB328i's Car Details
    Model of Car:
    350i
    Year of Manufacture:
    1989
    Transmission Type:
    manual
    Car Body Type:
    2 door vert
    RJB328i's Avatar
    Join Date
    Apr 2009
    Location
    surrey
    Posts
    5,675
    Thanks
    7,052
    Thanked 6,626 Times in 4,238 Posts
    will did you get all the stuff off the same car mate, if so check your connection, sorry cant be any further help
     
     

  7.  
    #5
    BMW Fanatic
    Car Details
    Willem's Car Details
    Model of Car:
    M3 Evolution - now sold
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Aug 2009
    Location
    London
    Posts
    80
    Thanks
    14
    Thanked 30 Times in 13 Posts
    had another scratch around today - found I have no power on the coils' terminals 15 (from the ignition) - traced backwards and found the problem. happy days!!!
    Last edited by Willem; 10-02-2010 at 15:41.
     
     

  8.  
    #6
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Still something to do with EWS not sending ignition signal I think.
     
     

  9.  
    #7
    Dr of BMW
    Car Details
    Diablo944's Car Details
    Model of Car:
    325 ti compact sport
    Year of Manufacture:
    2002
    Transmission Type:
    leadfoot sport trip
    Car Body Type:
    compact
    Diablo944's Avatar
    Join Date
    Mar 2009
    Location
    uk
    Posts
    1,182
    Thanks
    81
    Thanked 398 Times in 312 Posts
    Quote Originally Posted by Willem View Post
    had another scratch around today - found I have no power on the coils' terminals 15 (from the ignition) - traced backwards and found the problem. happy days!!!

    by happy days, does that mean its running?
    2002 325 Compact Sport ti M-Tec---- A little thanks goes a long way
     
     

  10.  
    #8
    BMW Fanatic
    Car Details
    Willem's Car Details
    Model of Car:
    M3 Evolution - now sold
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Aug 2009
    Location
    London
    Posts
    80
    Thanks
    14
    Thanked 30 Times in 13 Posts
    yes mate all good now. :-)
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts