1997 E39 528iSE Touring Service light problem

Notices
 

Thread: 1997 E39 528iSE Touring Service light problem

Reply to Thread
Results 1 to 8 of 8
  1. 1997 E39 528iSE Touring Service light problem 
    #1
    BMW Fanatic
    Car Details
    Dawn's Car Details
    Model of Car:
    528i SE
    Year of Manufacture:
    1997
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Jan 2009
    Location
    Rotherham
    Posts
    38
    Thanks
    12
    Thanked 18 Times in 6 Posts
    Hi to all,

    Can anyone tell me why NONE of my service lights come on EVER.

    I can see the shapes and colours of them in the dash but they do not light up at all when ignition is turned on or engine started.

    I have only just got the car, my first BMW and it seems to run ok but am baffled why none of the lights is active! I have heard of people resetting the SI lights but surely this would mean the green ones should show before starting?

    Any help will be appreciated.............Al
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3. A thought! 
    #2
    BMW Fanatic
    Car Details
    Dawn's Car Details
    Model of Car:
    528i SE
    Year of Manufacture:
    1997
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Jan 2009
    Location
    Rotherham
    Posts
    38
    Thanks
    12
    Thanked 18 Times in 6 Posts
    I just wondered if there is a single bulb backlight for the entire service light box, if so then maybe its gone and I will need to get the cluster out.

    I will be taking the cluster out soon anyway as I have the missing pixels problem and will be following the Utube how to, to have a go at fixing them!

    Al
     
     

  4.  
    #3
    Administrator
    Car Details
    Ian S's Car Details
    Model of Car:
    M3 Evo, E60 530D, 911 C4S, Yaris T Sport
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Loon
    Ian S's Avatar
    Join Date
    Jun 2008
    Location
    Bristol
    Posts
    3,960
    Thanks
    2,146
    Thanked 2,253 Times in 1,723 Posts
    The service lights are powered by nicad batteries and from the symptoms you descirbe it sounds like the batteries have failed.

    From what I have read they sound like a royal PITA to change as they are soldered on. I have never found the lights that useful but if you are interested in repairing them, post back and I'll see what I can find.
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6. Update 
    #4
    BMW Fanatic
    Car Details
    Dawn's Car Details
    Model of Car:
    528i SE
    Year of Manufacture:
    1997
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Jan 2009
    Location
    Rotherham
    Posts
    38
    Thanks
    12
    Thanked 18 Times in 6 Posts
    Quote Originally Posted by Dawn View Post
    I just wondered if there is a single bulb backlight for the entire service light box, if so then maybe its gone and I will need to get the cluster out.

    I will be taking the cluster out soon anyway as I have the missing pixels problem and will be following the Utube how to, to have a go at fixing them!

    Al
    Right! Just been and looked at the display again and its the first time I've seen it at night. The SI box does light up! But none of the little coloured squares is brighter than another, so I'm no wiser! :(

    Al
     
     

  7.  
    #5
    BMW Fanatic
    Car Details
    Dawn's Car Details
    Model of Car:
    528i SE
    Year of Manufacture:
    1997
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Jan 2009
    Location
    Rotherham
    Posts
    38
    Thanks
    12
    Thanked 18 Times in 6 Posts
    Quote Originally Posted by Ian S View Post
    The service lights are powered by nicad batteries and from the symptoms you descirbe it sounds like the batteries have failed.

    From what I have read they sound like a royal PITA to change as they are soldered on. I have never found the lights that useful but if you are interested in repairing them, post back and I'll see what I can find.
    Thanks mate,

    I will try and get the cluster out tom, if it doesn't pee it down again, and will post some pics.

    Thanks.......Al
     
     

  8.  
    #6
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    How to remove the clocks and the bulbs are shown http://www.pelicanparts.com/bmw/tech...-90-Gauges.htm

    IIRC the clocks on the e39 are very similar to the e36
     
     

  9. Update on service indicators 
    #7
    BMW Fanatic
    Car Details
    Dawn's Car Details
    Model of Car:
    528i SE
    Year of Manufacture:
    1997
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Jan 2009
    Location
    Rotherham
    Posts
    38
    Thanks
    12
    Thanked 18 Times in 6 Posts
    Hi Ronnie and Ian S,

    Today the weather was great and it gave me a chance to remove the cluster!

    As to Ians suggestion about NiCads powering the SI lights, I couldn't see any evidence of any, but I did solve the problem, well to a degree anyway.

    After stripping the clocks I realised that the SI indicators are PART of the information display LCD panel and weren't working for the same reason that my info display was corrupted - the famous missing pixels!

    I followed this excellent how to http://www.bimmerboard.com/forums/posts/543597 without which I would never have figured out how get the thing apart and the only part I changed in the how to was that I used my soldering iron to melt the holes instead of drilling them (my bottle went at the drilling prospect) and it worked fine.

    Anyway after the first attempt I now have a much clearer information section that is easily readable now, and finally some parts of the SI lights, though not perfectly formed I can now see one green square and possibly two more

    So hopefully with one or two more goes at it I should get it all looking as it should.

    BTW its great to finally have a BMW instead of just drooling over other peoples! Also after lurking for some time on this forum I feel like I already know some of you, especially Ronnie, who must have answered more posts than most!

    Thanks again guys and is nice to be part of such a great forum.

    Al (Dawns other half)
     
     

  10. The Following User Says Thank You to Dawn For This Useful Post:

    Ronnie (16-03-2009)

  11.  
    #8
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    Quote Originally Posted by Dawn View Post
    Also after lurking for some time on this forum I feel like I already know some of you, especially Ronnie, who must have answered more posts than most!

    Thanks again guys and is nice to be part of such a great forum.

    Al (Dawns other half)
    Good to hear you are getting there Al/Dawn and hello from me, nice cup of tea you made me the other day
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts