1997 E36 318td dash problem Urgent please!!

Notices
 

Thread: 1997 E36 318td dash problem Urgent please!!

Reply to Thread
Results 1 to 3 of 3
  1. 1997 E36 318td dash problem Urgent please!! 
    #1
    Bimmer Fan
    Car Details
    smokinmasta's Car Details
    Model of Car:
    318 tds se
    Year of Manufacture:
    1997
    Transmission Type:
    maunal
    Car Body Type:
    saloon
    smokinmasta's Avatar
    Join Date
    Apr 2009
    Location
    Norfolk UK
    Posts
    20
    Thanks
    6
    Thanked 2 Times in 2 Posts
    Hi - i appear to have lost nearly all functions on my dash!!!!
    Handbrake light stays on, no tacho,no temp gauge, econ meter and fuel gauge appears to stay where it was before it stopped (although this drops to empty on ign off, but back to where it where it started). HELP!!!!

    Also the air vents are useless, knob changes direction of flow, very little air comes out no matter what speed it is set at!!


    Thanks
    Last edited by smokinmasta; 02-07-2009 at 19:01.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    smokinmasta's Car Details
    Model of Car:
    318 tds se
    Year of Manufacture:
    1997
    Transmission Type:
    maunal
    Car Body Type:
    saloon
    smokinmasta's Avatar
    Join Date
    Apr 2009
    Location
    Norfolk UK
    Posts
    20
    Thanks
    6
    Thanked 2 Times in 2 Posts
    PS i've check the fuses relevant to the instrument panel - and all the other come to that !!
     
     

  4.  
    #3
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    You tried a binnacle test?

    Do a binnacle test, Hold down the mileage reset button with the ignition off, turn the ignition key to position 1, Wait for TEST to appear and then release reset button, watch as the binnacle does a self test.

    If gauges move then they are fine
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts