1996 E39 523i - traction/abs/speedo problem

Notices
 

Thread: 1996 E39 523i - traction/abs/speedo problem

Reply to Thread
Results 1 to 2 of 2
  1. 1996 E39 523i - traction/abs/speedo problem 
    #1
    Banned
    Car Details
    andrewc1267's Car Details
    Model of Car:
    523i
    Year of Manufacture:
    1996
    Transmission Type:
    manual
    Car Body Type:
    salon

    Join Date
    Nov 2009
    Location
    manchester
    Posts
    33
    Thanks
    0
    Thanked 6 Times in 4 Posts
    hi i was out in the car this morning in the snow and the traction and abs light came on and stayed on and the speedo stopped working any ideas thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Deano16v's Car Details
    Model of Car:
    745i
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    Kent
    Posts
    3,632
    Thanks
    652
    Thanked 1,154 Times in 1,001 Posts
    if the speedo stopped working then your NSR wheel speed sensor has shown up as a fault. It could well be that the excessive wheel spinning has caused it to flag. When you next start it up see if it comes back on, it may well do when you start it but should go off after a while, if not then the sensor is fubared
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts