1996 E36 328ic battery wrong way around..help!? - Page 2

Notices
 

Thread: 1996 E36 328ic battery wrong way around..help!?

Reply to Thread
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1.  
    #11
    Bimmer Fan
    Car Details
    knaprigt's Car Details
    Model of Car:
    328ic
    Year of Manufacture:
    1996
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jul 2010
    Location
    sweden
    Posts
    8
    Thanks
    7
    Thanked 0 Times in 0 Posts
    Again, THANX a lot for all your advice!
    I did check the relay, and it seems to be working fine, i took the plastic-cup off it, and it seems to do just what it is supposed to.
    And i did measure it with a pen aswell, seems all wiring is intact.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #12
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    Have you tryed disconecting the main positive to the alternator and see if ignition comes up.

    I would have thought something else abit weaker would have blown apart from the ECU. You'll have to start looking for a ECU/KEY/EWS box
     
     

  4.  
    #13
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    Forgot to say, look closely at the ECU circuit board for hairline cracks in the PCB.

    I know its different but I "blew" a Kenwood amp few years ago buy reversing polarity accidently and fortunatley the strip on the PCB had broke just before the high power diodes Resoldered a wire over the top and jobs a good un.

    Something worth checking before splashing out big money.
     
     

  5.  
    #14
    BMW Guru
    Car Details
    E36Coupe328's Car Details
    Model of Car:
    328 + 325
    Year of Manufacture:
    1995 + 1994
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    E36Coupe328's Avatar
    Join Date
    Jul 2010
    Location
    UK
    Posts
    2,970
    Thanks
    225
    Thanked 1,089 Times in 956 Posts
    I would be tempted to check I was getting ignition lives / permanant lives and earths at the appropriate pins in the DME connector.

    At the moment it doesn't appear certain whether there is any power at the DME. Once you are really sure about that you will have a better idea.

    I don't know if it's possible but with some improvisation maybe it's possible to hook diagnostics to the DME off the car?

    If you bought a DME, EWS and the other bits as a set of ebay, as long as you have faith the loom isn't damaged you could test by substitution.

    If that fixes it you would have bought the bits you need to fix it already and saved time.

    If not and you don't damage them you have eliminated them and can hopefully recoupe the money by reselling once your car is running.

    The risk on the above being a metled loom damaging replacement parts.

    (No warranty of any kind implied or given)
     
     

  6.  
    #15
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    Check your ignition barrell, Don't think that would like power the wrong way round either..
     
     

  7. i did check... 
    #16
    Bimmer Fan
    Car Details
    knaprigt's Car Details
    Model of Car:
    328ic
    Year of Manufacture:
    1996
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jul 2010
    Location
    sweden
    Posts
    8
    Thanks
    7
    Thanked 0 Times in 0 Posts
    Thanx again for all of your effort!
    I DID check the lives and grounds at the dme..and i found that two lives were missing...so i checked the wiring diagram, and they both came from the fuel-relay..so i checked the pins under that relay, and found that power was missing from pin number 8 (i hope i recall it correct, as i remember the other live one is number 6, and that wire comes directly from the battery) And where that comes from..only god seems to know......
    And seems i got no spark aswell.....
    Honestly....i am all out of ideas, and really, really low on nerves....
     
     

  8.  
    #17
    BMW Guru
    Car Details
    billywhizz1984's Car Details
    Model of Car:
    E36 323i x 3, 325TDS x 1, 320i x 2, 318is x 1
    Year of Manufacture:
    1999 x 2, 1998, 1997 x 2, 1996, 1995
    Transmission Type:
    Manual, Auto, Auto, Manual, Auto, Auto, Manual
    Car Body Type:
    Touring x 4, Convertible x 2, Coupe x 1
    billywhizz1984's Avatar
    Join Date
    Sep 2009
    Location
    North East
    Posts
    2,493
    Images
    4
    Thanks
    165
    Thanked 932 Times in 703 Posts
    If the DME has survived it could just be that the immobiliser has been activated. Read this and post your thoughts....

    http://www.bimmerforums.co.uk/forum/...ersion-t60240/
     
     

  9.  
    #18
    BMW Guru
    Car Details
    E36Coupe328's Car Details
    Model of Car:
    328 + 325
    Year of Manufacture:
    1995 + 1994
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    E36Coupe328's Avatar
    Join Date
    Jul 2010
    Location
    UK
    Posts
    2,970
    Thanks
    225
    Thanked 1,089 Times in 956 Posts
    Quote Originally Posted by knaprigt View Post
    Thanx again for all of your effort!
    I DID check the lives and grounds at the dme..and i found that two lives were missing...so i checked the wiring diagram, and they both came from the fuel-relay..so i checked the pins under that relay, and found that power was missing from pin number 8 (i hope i recall it correct, as i remember the other live one is number 6, and that wire comes directly from the battery) And where that comes from..only god seems to know......
    And seems i got no spark aswell.....
    Honestly....i am all out of ideas, and really, really low on nerves....
    Does that mean you could rig power to the DME to get a diagnostic out of it to see if it is dead or not? Might save you hours trying to get the car working and checking stuff if it's a paperweight.

    No warranty implied or given


    No warranty of any kind implied or given and no liability for any loss, damage or injury, no matter how incurred accepted.

    Free Gas Kit* now fitted to free 328*

    *Based on ROI period exceeded
     
     

  10. Thank you! 
    #19
    Bimmer Fan
    Car Details
    knaprigt's Car Details
    Model of Car:
    328ic
    Year of Manufacture:
    1996
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jul 2010
    Location
    sweden
    Posts
    8
    Thanks
    7
    Thanked 0 Times in 0 Posts
    Hey guys!
    I just got my car back yesterday. I ended up taking it to a shop after all.....and it turned up to be the DME, there were some damaged components, and some expert got them changed.... now she runs again...
    428 euros...

    Well anyway, i just wanted to thank you all for all of your great tips along the way!!!
    So once again, THANK YOU!
     
     

Page 2 of 2 FirstFirst 12
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts