1996 E36 325tds - Instrument lights staying on

Notices
 

Thread: 1996 E36 325tds - Instrument lights staying on

Reply to Thread
Results 1 to 7 of 7
  1. 1996 E36 325tds - Instrument lights staying on 
    #1
    Bimmer Fan
    Car Details
    monkeyhanger's Car Details
    Model of Car:
    325tds touring
    Year of Manufacture:
    1996/97
    Transmission Type:
    auto
    Car Body Type:
    touring

    Join Date
    Jan 2010
    Location
    Hartlepool
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Hi All,
    I have a 1996 325tds touring(auto)the problem i have is when i remove the keys and turn of lights my dash & centre consul lights remain on along with my number plate lights.
    I have got hold of a used ecu for the interior lights and central locking ,but after a rethink may not solve the problem(and i can`t find were it fits lol)
    Any help or advise is appreciated..
    Thanks in advance Andy
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    Check fuse 37 just in case theres any funny wiring issues going on..

    Sounds like you may have a faulty light switch, unless there's some wiring issue.
    If you take out the light switch and unplug the wiring connector and the lights go out, then I would suspect the switch.
    With the switch out if you test for continuity with a multimeter across the pins that would normally have a red/blue wire and a grey/black on them (pins 1 and 11?). Check if the circuit makes and breaks when you operate the switch. If you get continuity in off and on the switch is dobbered.
     
     

  4. The Following User Says Thank You to gildersol For This Useful Post:

    monkeyhanger (16-01-2010)

  5.  
    #3
    Bimmer Fan
    Car Details
    monkeyhanger's Car Details
    Model of Car:
    325tds touring
    Year of Manufacture:
    1996/97
    Transmission Type:
    auto
    Car Body Type:
    touring

    Join Date
    Jan 2010
    Location
    Hartlepool
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Thanks for reply will get that checked.
    Andy
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Bimmer Fan
    Car Details
    monkeyhanger's Car Details
    Model of Car:
    325tds touring
    Year of Manufacture:
    1996/97
    Transmission Type:
    auto
    Car Body Type:
    touring

    Join Date
    Jan 2010
    Location
    Hartlepool
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    tried switch all appears well as does fuses,any further suggestions(quickly its bloody cold out here lol)
    Also i don`t seem able to locate the lighting module/ecu help please
    Andy
     
     

  8.  
    #5
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    Did you unplug the light switch?What happened?
    Check the wiring harness that goes from the car into the tailgate beside the hinge as the wires can break and become bare and cause various issues.
     
     

  9.  
    #6
    Bimmer Fan
    Car Details
    monkeyhanger's Car Details
    Model of Car:
    325tds touring
    Year of Manufacture:
    1996/97
    Transmission Type:
    auto
    Car Body Type:
    touring

    Join Date
    Jan 2010
    Location
    Hartlepool
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Unplugged switch and the lights stayed on,mmmmmmmmm??????
    Checked both front door switch`s (linked them out) no change??
    Parked car up and lights went out,this is getting bizzare.
    all i can think(makes no sense to me)i unplugged tailgate central locking solenoid and removed it(stopped working)could this be linked????
    Thanks Andy
     
     

  10.  
    #7
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    Do you know if the solenoid stopped working because it was duff, or could it have been not getting power to it. If this was the case then it could be related to the wiring harness I mentioned earlier. If you read the bit at the bottom of this link, it shows what i'm on about
    http://www.pelicanparts.com/bmw/tech...l-Problems.htm
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts