1996 E36 325i - Electrical Problems

Notices
 

Thread: 1996 E36 325i - Electrical Problems

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. 1996 E36 325i - Electrical Problems 
    #1
    BMW Fanatic
    Car Details
    BMWJamesy's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2008
    Location
    Linlithgow
    Posts
    41
    Thanks
    4
    Thanked 5 Times in 4 Posts
    Hey all,

    Got a few electric problems now!!

    1. The window wash & wiper system does not work the guy fitting my stereo sparked the live lines when this happened is was fine before but not now.

    2. The stereo is getting power but not coming on I have tried three diff stereos all doing same thing dunno if it related to wiper problem?

    3. The dash lights are not working this was like this before any of the other 2 problems.

    Ive checked all fuses and all intact Im not sure where relays (if are any for these) are situated. Hopefully some of you guys can lend a helping hand and help me sort these problems

    Thanks for looking guys.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    1. It sounds like the window/washer module behind the dash has been damaged.
    2. You will have to explain what stereos are being used as you still may have faulty wiring.
    3. This is down to the individual cluster bulbs that probably require changing.
     
     

  4.  
    #3
    BMW Fanatic
    Car Details
    BMWJamesy's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2008
    Location
    Linlithgow
    Posts
    41
    Thanks
    4
    Thanked 5 Times in 4 Posts
    Hi mate,

    Thanks for help I will have a look and the stereos are a dvd player and jvc cd player they are getting power but the displays and functions are not coming up to use them. Seems to be something else was damaged when the guy wrecked my wiring
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Use a test light and check for power at the fuses
     
     

  7.  
    #5
    BMW Fanatic
    Car Details
    BMWJamesy's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2008
    Location
    Linlithgow
    Posts
    41
    Thanks
    4
    Thanked 5 Times in 4 Posts
    hey again guys,

    unfortunately it was not the module I replaced all three as one was burned out but looks like it has for a long while there is power to the fuses also Im totally stumped
     
     

  8.  
    #6
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
     
     

  9.  
    #7
    BMW Fanatic
    Car Details
    BMWJamesy's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2008
    Location
    Linlithgow
    Posts
    41
    Thanks
    4
    Thanked 5 Times in 4 Posts
    hey ronnie,

    thanks for that Ive had a look going to try somethings but going to try wiper stalks see what happens then cos everything seems in order just seems to be a switch so I will try this hopefully solve my problem

    Still cant work out the dash light problem though, no lights are coming on atal including dash, control switches, heater control, window switches dunno if it possibly a dodgey switch too just have to keep plugging away thanks for your help again
     
     

  10.  
    #8
    RYM
    RYM is offline
    Legendary BFuk Member
    Car Details
    RYM's Car Details
    Model of Car:
    325tds
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    RYM's Avatar
    Join Date
    Apr 2008
    Location
    Bristol
    Posts
    12,959
    Thanks
    5,540
    Thanked 4,935 Times in 3,119 Posts
    James your other thread has been deleted as it is a duplicate of this one. Please continue to post the problem in here so as not to clog up the forum and miss out on information

    Each time you "BUMP" or post in a thread it is brought back to the top of the list
     
     

  11.  
    #9
    BMW Fanatic
    Car Details
    BMWJamesy's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2008
    Location
    Linlithgow
    Posts
    41
    Thanks
    4
    Thanked 5 Times in 4 Posts
    ok sorry about that,

    well here goes again guys, my wipe/wash system is not working I have checked module, fuses which are all getting power, ive read in manual there is relays but not wipe wash just wiper and wiper motor relays. There is 2 ignition uploader relays in same area where these are, could these possibly be problem? Any ideas would be muchly appreciated thanks again.
     
     

  12.  
    #10
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Have you checked for power at the wiper switch?
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts