1996 E36 318i convertible - roof module fault - Page 2

Notices
 

Thread: 1996 E36 318i convertible - roof module fault

Reply to Thread
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. Same Problem 
    #11
    Bimmer Fan
    Car Details
    ddavett's Car Details
    Model of Car:
    3 series
    Year of Manufacture:
    1998
    Transmission Type:
    manual
    Car Body Type:
    convertible

    Join Date
    Apr 2012
    Location
    London
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by danfa View Post
    Hi to all, I hope somebody can help me as this is driving me mad!!
    I have recently bought an e36 convertible with fully automatic roof, brilliant but the roof doesnt work at all!!. I have checked the motors 1 by 1 to see if they operate if i put power to them and they are all fine. I have checked the micro switches which all seem fine too!!!!. I have done the reset procedure which when that is done all I get is a clicking noise from n/s/f behind glovebox (no motor operation) and all the windows go down in stages but no motor noise what-so-ever, the rear tourneau cover doesnt even lock down as it says in the manual that has been posted before??? I have today checked the wiring that I could find and didnt see any obvious damage, I have taken the roof control module appart to check the circuit board and have found that a little black box on the circuit board has burnt out and opened up...... Does anyone know what the box is for and whether it is going to be the root of the problem or is it just an aftermath. I dont want to buy another control module only to burn another one out. I appreciate all your help
    I have this exact same problem, with the random clicking coming from behind the glove box also. RHD.

    Can anyone help/ managed to fix a similar problem?

    I'm thinking of just buying new motors to see if it fixes it.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #12
    kib
    kib is offline
    BMW Master
    Car Details
    kib's Car Details
    Model of Car:
    e46 330 ci
    Year of Manufacture:
    2004
    Transmission Type:
    auto
    Car Body Type:
    convertible

    Join Date
    Feb 2010
    Location
    worcester park
    Posts
    358
    Thanks
    1
    Thanked 61 Times in 61 Posts
    have you checked fluid level if low that wont help.
     
     

  4.  
    #13
    Bimmer Fan
    Car Details
    JasonR-325i's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1988
    Transmission Type:
    Manual
    Car Body Type:
    saloon

    Join Date
    Mar 2011
    Location
    Burgess hill
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Any progress with this problem? I recently bought a 328 Cab and have a similar issue.
     
     

  5. 318i Electrical Roof Problem 
    #14
    Bimmer Fan
    Car Details
    WhateverMan's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Convertible

    Join Date
    Jul 2013
    Location
    United Kingdom
    Posts
    2
    Images
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Skallesei View Post
    Hey...
    How is your problem coming along danfa? Have u found a solution?

    I have a semi-auto 96model does the same thing.
    Pushing the "roof off" button, my windows start to go down and stop...
    Then i drive my windows all the way down with the down window button and press the "roof off" button again, the back of the cab lifts up 90degrees and the roof lid that covers the cab when the roof is off starts to open and stops. Opens a couple of more inches and stops again. It starts and stops like 5 times until it's fully open and then nothing more happens.
    Now nothing happens when i push either up and down on the cab button.......
    I haveto release the motors with the lever underneath the back seat to get the cab back on or off. When i take the roof off i use the reset procedure to lock the cab-lid.
    Now when i want to put the roof back on/up i press the "roof up" button and the cab-lid starts to open the same way as earlier. Starts and stops like 5 times until it's fully open and then nothing more happens again. The motors that drag the roof back up will not engage at all. Now, i haveto pull the lever again to release the motors so i can get my roof back up and lock it in place in the front.

    All my wiring seems perfectly fine, but sometimes my passenger door does not unlock with the central locking using the key on the drivers side door. If i lock it again and then unlock once more, it unlocks perfectly fine. This only happens once in a while. =)

    Hope u understand... :P

    All sensors seem fine so i don't know what else than the Control Module Box it can be?

    Any suggestions?
    Hey Skallesei,

    Mines The Exact Same Problem Must Be a Common Fault on Old Beemers? I Have Same Year and Semi Auto, Same Fault Pftt, I am Trying to Get Somebody To Check Roof Module and Try and Get Fault Codes Then Go From There if u Know What I Mean, If I Cure The Problem I Will Post it on Here! There Must Be Loads of us With The Same Electrical Prob! If any Member Have Cured it PLEASE POST.... So We Can Sleep at Night. Thanx Jim
     
     

Page 2 of 2 FirstFirst 12
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts