1995 E36 325i Saloon brake light Failure (FIXED)

Notices
 

Thread: 1995 E36 325i Saloon brake light Failure (FIXED)

Reply to Thread
Results 1 to 7 of 7
  1. 1995 E36 325i Saloon brake light Failure (FIXED) 
    #1
    Platinum BFuk Member
    Car Details
    bigedd9990's Car Details
    Model of Car:
    B3s , 320d
    Year of Manufacture:
    2004, 2002
    Transmission Type:
    Switchtronic, Manual
    Car Body Type:
    Coupe, Touring
    bigedd9990's Avatar
    Join Date
    Mar 2009
    Location
    Lanarkshire, Scotland
    Posts
    881
    Thanks
    279
    Thanked 365 Times in 278 Posts
    kept on getting brake light failure on my check control, no big problem, when I checked them the brake lights were working so never thought anymore about it. until yesterday when it came back on again but this time would come on as soon as you pressed the peddle, any other time it would be after driving for a while. none of my brake lights are working not even my spoiler one, when I have the radio on MW, when you press the peddle, you hear the power interfering with the radio. So im thinking theres power going to them, the peddle switch must be working, Ive changed the bulbs to known working ones so whats the problem will I need to get the test lamp out anybody want to talk me through a test for the brake lights
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    The fuse is F46 by the way.

    Make sure the bulbs are making a good connection at the cluster - no corrosion etc

    Could be the brake light switch or a bad earth Ed.
    Get someone to press the brake and check for voltage at the cluster.
    On one of the clusters the +ve wire is blue/brown and the other cluster is blue/red.
    Test between the +ve wire and the brown wire. If nothing, test to a good earth. If it works now it's probably an earth problem.

    As for the switch, you should have a 4 pin one. Unplug it and short across the violet/yellow and blue/red wires with a piece of wire. If the lights work the switch is U/S.

    Hope that helps
     
     

  4. The Following User Says Thank You to gildersol For This Useful Post:

    bigedd9990 (20-09-2009)

  5.  
    #3
    Platinum BFuk Member
    Car Details
    bigedd9990's Car Details
    Model of Car:
    B3s , 320d
    Year of Manufacture:
    2004, 2002
    Transmission Type:
    Switchtronic, Manual
    Car Body Type:
    Coupe, Touring
    bigedd9990's Avatar
    Join Date
    Mar 2009
    Location
    Lanarkshire, Scotland
    Posts
    881
    Thanks
    279
    Thanked 365 Times in 278 Posts
    Thanks for that gildersol, I'll give it a go tomorrow and post back the results I checked for the corrosion with the bulbs but they seem fine the spoiler light isn't coming on either so looks more like what you are saying about the earth/switch problem.
    Last edited by bigedd9990; 20-09-2009 at 11:37.
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Platinum BFuk Member
    Car Details
    bigedd9990's Car Details
    Model of Car:
    B3s , 320d
    Year of Manufacture:
    2004, 2002
    Transmission Type:
    Switchtronic, Manual
    Car Body Type:
    Coupe, Touring
    bigedd9990's Avatar
    Join Date
    Mar 2009
    Location
    Lanarkshire, Scotland
    Posts
    881
    Thanks
    279
    Thanked 365 Times in 278 Posts
    After checking all the other items, shorted across the violet/yellow and blue/red wires at the peddle switch with a piece of wire, and hey presto they came on. So I gave the connections a clean plugged it back on to the switch and they seem to be working with no issue's. I'll keep an eye on it. The switch might be on its way out, but there working at the moment. thanks again Gildersol, the leccy guru
     
     

  8.  
    #5
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    Good stuff. You're pretty handy with the leccy stuff yourself now
     
     

  9.  
    #6
    Platinum BFuk Member
    Car Details
    bigedd9990's Car Details
    Model of Car:
    B3s , 320d
    Year of Manufacture:
    2004, 2002
    Transmission Type:
    Switchtronic, Manual
    Car Body Type:
    Coupe, Touring
    bigedd9990's Avatar
    Join Date
    Mar 2009
    Location
    Lanarkshire, Scotland
    Posts
    881
    Thanks
    279
    Thanked 365 Times in 278 Posts
    Quote Originally Posted by gildersol View Post
    Good stuff. You're pretty handy with the leccy stuff yourself now

    I've Had plenty of practise with this car, cheers again
     
     

  10.  
    #7
    Platinum BFuk Member
    Car Details
    bigedd9990's Car Details
    Model of Car:
    B3s , 320d
    Year of Manufacture:
    2004, 2002
    Transmission Type:
    Switchtronic, Manual
    Car Body Type:
    Coupe, Touring
    bigedd9990's Avatar
    Join Date
    Mar 2009
    Location
    Lanarkshire, Scotland
    Posts
    881
    Thanks
    279
    Thanked 365 Times in 278 Posts
    Problem started again, the switch must have been nackered

    Bought a new Brake peddle switch yesterday 17 quid +vat from dealer.

    Fitted it and brake lights, I can report are all OK no problems
     
     

  11. The Following User Says Thank You to bigedd9990 For This Useful Post:

    gildersol (26-09-2009)

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts