1995 E36 320i -non A/C Heater blower help

Notices
 

Thread: 1995 E36 320i -non A/C Heater blower help

Reply to Thread
Results 1 to 6 of 6
  1. 1995 E36 320i -non A/C Heater blower help 
    #1
    BMW Crazed
    Car Details
    dx90's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    Build Date August 1995
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Apr 2009
    Location
    UK
    Posts
    237
    Thanks
    0
    Thanked 9 Times in 8 Posts
    I have a none A/C 320i 1995 August build manual.

    The blower when turned to cold still puts out hot air. Like the heater is still half on.
    If I turn the heater fully up it gets a lot hotter like it should. But when I turn it to coolest it gets less hoter but it is still blowing out hot air. Its almost like it doesn't shut the hot air flow off completely to allow the the outside cooler air in.

    I'm having to shut the blower off completely at the moment which is utter madness in this weather.

    Anyone got any ideas what the problem could be?
    dx90
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Have you checked the operation of the heater taps?

    Also have a read here http://www.bimmerforums.co.uk/forum/...-vents-t18284/
     
     

  4.  
    #3
    BMW Crazed
    Car Details
    dx90's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    Build Date August 1995
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Apr 2009
    Location
    UK
    Posts
    237
    Thanks
    0
    Thanked 9 Times in 8 Posts
    Had a read from the link and the problem sounds just like the one I have. I'll give some testing later and post back with my findings.

    Do you know if it's normal for the Idle Regulating Valve it to make a load buzzing noise when the ignition is switched on?
    It also does it when the engine is running.


    Thanks
    dx90
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Crazed
    Car Details
    dx90's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    Build Date August 1995
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Apr 2009
    Location
    UK
    Posts
    237
    Thanks
    0
    Thanked 9 Times in 8 Posts
    Can someone please disconnect there heater control valve in the engine bay and put a multi meter on the end and give me the voltages that come from the heater control panel when the control is,

    1. Fully in the cold position?
    2. Fully in the hot position?
    3. In the middle of both?

    Does anyone know if the 12 volts closes or opens the heater control valve?
    dx90
     
     

  7.  
    #5
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Quote Originally Posted by dx90 View Post
    Had a read from the link and the problem sounds just like the one I have. I'll give some testing later and post back with my findings.

    Do you know if it's normal for the Idle Regulating Valve it to make a load buzzing noise when the ignition is switched on?
    It also does it when the engine is running.


    Thanks
    The Idle control valve is common for buzzing with the ignition on
     
     

  8.  
    #6
    BMW Crazed
    Car Details
    dx90's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    Build Date August 1995
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Apr 2009
    Location
    UK
    Posts
    237
    Thanks
    0
    Thanked 9 Times in 8 Posts
    That's good news. I have another problem now though With the heater control in the car. When on cold the 12 volts that keeps the heater control valve shut is not constant. This explains the hot air flow. So the control in the car is faulty. Plus there is no smooth 0V - 12 volts on the control. Its either all or nothing. I have the E36 1995 none A/C 320i. On realoem.com it shows two heater control units that fits my car.
    1. Siemens heater control.
    2. Kammerer heater control.

    Do you know if these are interchangeable with the existing wiring and control cables that are in the car?

    I have just purchased one. Thinking there all the same and I don't want to pay for it if it wont fit. The one I purchased just says its for an E36. So it could be either.

    Thanks
    dx90
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts