1995 E34 530i - No brake lights

Notices
 

Thread: 1995 E34 530i - No brake lights

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. 1995 E34 530i - No brake lights 
    #1
    Bimmer Fan
    Car Details
    E34V8's Car Details
    Model of Car:
    530i
    Year of Manufacture:
    1995
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    epsom
    Posts
    9
    Thanks
    3
    Thanked 0 Times in 0 Posts
    My brake lights have stopped working (including LED) I have checked the fuses and replaced the switch. I can't think of anything else that can cause this problem.
    Can anyone please help?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Have you checked for power(voltage) at the brake light switch?
     
     

  4. The Following User Says Thank You to Ronnie For This Useful Post:

    E34V8 (15-07-2009)

  5.  
    #3
    Bimmer Fan
    Car Details
    E34V8's Car Details
    Model of Car:
    530i
    Year of Manufacture:
    1995
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    epsom
    Posts
    9
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thanks Simon. Yes I have checked for voltage and this is ok.
    I am beginning to think that the new switch is faulty or they have given me the wrong one.
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Bimmer Fan
    Car Details
    E34V8's Car Details
    Model of Car:
    530i
    Year of Manufacture:
    1995
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    epsom
    Posts
    9
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Ronnie View Post
    Have you checked for power(voltage) at the brake light switch?
    Yes I checked and I have power
     
     

  8.  
    #5
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    Have you check for power at the live side of the switch and at the switched side when pressing the pedal?
     
     

  9.  
    #6
    Bimmer Fan
    Car Details
    E34V8's Car Details
    Model of Car:
    530i
    Year of Manufacture:
    1995
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    epsom
    Posts
    9
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by gildersol View Post
    Have you check for power at the live side of the switch and at the switched side when pressing the pedal?
    I have checked for power at the live side of switch i.e. pulling connector off switch, but how do you test for power when pressing ther pedal? how do you access the wires if it is connected to the switch?
     
     

  10.  
    #7
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Quote Originally Posted by E34V8 View Post
    Thanks Simon.
    Who's Simon? ...he only plays the game when he's bored

    Quote Originally Posted by E34V8 View Post
    I have checked for power at the live side of switch i.e. pulling connector off switch, but how do you test for power when pressing ther pedal? how do you access the wires if it is connected to the switch?
    Maybe you can get someone to press the brake pedal while you check for voltage at the cluster side.
     
     

  11.  
    #8
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    You could unplug the switch and short across the pins. If the lights work then the switch is at fault.
    If you need help, tell me what colour the wires are going to the switch
     
     

  12. The Following User Says Thank You to gildersol For This Useful Post:

    E34V8 (28-07-2009)

  13.  
    #9
    Bimmer Fan
    Car Details
    E34V8's Car Details
    Model of Car:
    530i
    Year of Manufacture:
    1995
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    epsom
    Posts
    9
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thank you - I will have a look at the wires tonight and get back to you
     
     

  14.  
    #10
    Bimmer Fan
    Car Details
    E34V8's Car Details
    Model of Car:
    530i
    Year of Manufacture:
    1995
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    epsom
    Posts
    9
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Sorry I did'nt get back to you sooner. The wires are as follows
    purple/yellow (live)
    blue/red
    brown
    brown (thin)
    I tried shorting the switch and blew the fuse.
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts