1994 525i e34 'Back to the future'/speedo problems !!!

Notices
 

Thread: 1994 525i e34 'Back to the future'/speedo problems !!!

Reply to Thread
Results 1 to 4 of 4
  1. 1994 525i e34 'Back to the future'/speedo problems !!! 
    #1
    BMW Crazed
    Car Details
    Phoenix81's Car Details
    Model of Car:
    328i msport
    Year of Manufacture:
    1997
    Transmission Type:
    manual
    Car Body Type:
    coupe
    Phoenix81's Avatar
    Join Date
    Jan 2009
    Location
    Harrogate, N.Yorks. Not the 'posh' bit
    Posts
    154
    Thanks
    162
    Thanked 93 Times in 72 Posts
    Evening all, im having issues with the speedo, rev counter and now its starting to affect my fuel gauge intermittently.

    Basically, as the title says, the dials basically spin round like nobodys business, clockwise, anti-clockwise. And most of the time im not registering anything once the car is warmed up, and in motion.

    Im hoping that this is a common fault, but im handyish with the tools, so if given the guidance i could 'fettle' it myself, after sourcing whatever parts i might need!!

    The n/s brake light works when it feels like it, as does the o/s sidelight!!

    Alot to take in for a first post, hope you can help!!

    Chris

    Forgot to say, 1994 525ie
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    RYM
    RYM is offline
    Legendary BFuk Member
    Car Details
    RYM's Car Details
    Model of Car:
    325tds
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    RYM's Avatar
    Join Date
    Apr 2008
    Location
    Bristol
    Posts
    12,959
    Thanks
    5,540
    Thanked 4,935 Times in 3,119 Posts
    I had a similar occurrence but it only affected the speedo and that was due to a faulty sensor on the diff
     
     

  4.  
    #3
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    The dial problems may be the cluster itself at fault or theirs a box that can play up, have a read here http://www.bmwe34.net/Wiki/tiki-inde...ard+capacitors
    As for the bulbs, check the bulb holders as they are really common for having a poor connection, you may need to clean the area up where they make contact
     
     

  5. The Following User Says Thank You to Ronnie For This Useful Post:

    Phoenix81 (10-01-2009)

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    BMW Crazed
    Car Details
    Phoenix81's Car Details
    Model of Car:
    328i msport
    Year of Manufacture:
    1997
    Transmission Type:
    manual
    Car Body Type:
    coupe
    Phoenix81's Avatar
    Join Date
    Jan 2009
    Location
    Harrogate, N.Yorks. Not the 'posh' bit
    Posts
    154
    Thanks
    162
    Thanked 93 Times in 72 Posts
    Thanks for your help!! il get onto it once the weather gets better
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts