1993 E36 M40 low idle when in drive or reverse


Thread: 1993 E36 M40 low idle when in drive or reverse

Reply to Thread
Results 1 to 2 of 2
  1. 1993 E36 M40 low idle when in drive or reverse 
    Bimmer Fan
    Car Details
    merlinnn's Car Details
    Model of Car:
    Year of Manufacture:
    Transmission Type:
    Car Body Type:

    Join Date
    May 2010
    Thanked 0 Times in 0 Posts
    Hi there everyone,

    I have been trawling through various bmw sites the last few weeks and despite from gathering lots of extremely usefull info I am unable to solve my problem so I have to ask for help.

    I have a 93 E36 with the M40 (I am in Australia) which is driving me crazy. The car will not idle correctly in drive or reverse, it basically drops to a point where everything starts to shake and vibrate, but will tick over perfectly in park or neutral. The car performs fine when driving.

    I have done the following recently;

    Fully rebuilt head after timing belt lost a few teeth!
    New waterpump, clutch fan, plugs, airfilter etc.
    Checked for air leaks, and that the gate on the MAF is free

    I have cleaned the original ICV multiple times, and even swapped it with several other secondhand units from other vehicles that were working ok.

    I have just cleaned the throttle body, and swappped the TPS with another without success tonight.

    My mechanic thinks it may be a faulty ECU??

    A couple of points to note are, if I disconnect the ICV the idle will rise to about 1100 rpm in park and will not drop when in drive or reverse, however if you put the aircon on the idle drops, I assume this is correct as when the ICV is connected the idle rises when the aircon is turned on.

    Several mechanics have looked for fault codes and found nothing

    I am desperate for help, any advice would be greatly appreciated

  2. Remove Advertisements

    BMW Guru
    Car Details
    billywhizz1984's Car Details
    Model of Car:
    E36 323i x 3, 325TDS x 1, 320i x 2, 318is x 1
    Year of Manufacture:
    1999 x 2, 1998, 1997 x 2, 1996, 1995
    Transmission Type:
    Manual, Auto, Auto, Manual, Auto, Auto, Manual
    Car Body Type:
    Touring x 4, Convertible x 2, Coupe x 1
    billywhizz1984's Avatar
    Join Date
    Sep 2009
    North East
    Thanked 932 Times in 703 Posts
    Sounds to me like the auto box is at fault here, effectively dragging the idle down when engaged. Could be the torque convertor, the brake band solenoid valve or an internal mechanical failure. Either way I'd start of by checking that all the linkages from the selector and the throttle are correctly adjusted and all electrical connections are good.

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts