1993 E36 325i - Solved battery not charging

Notices
 

Thread: 1993 E36 325i - Solved battery not charging

Reply to Thread
Results 1 to 3 of 3
  1. 1993 E36 325i - Solved battery not charging 
    #1
    BMW Crazed
    Car Details
    ukfrog's Car Details
    Model of Car:
    528i s
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    saloon
    ukfrog's Avatar
    Join Date
    May 2008
    Location
    South west
    Posts
    130
    Thanks
    0
    Thanked 4 Times in 1 Post
    E36, 325i, 1993.
    Like many out there, I have had a problem with my E36's battery, it didn't charge, and every so often I had to recharge it.
    Alternator was fine, starter was working too. checked lights ,looms.
    Finally, after having spent a lot of money in various garages and the fault still not being diagnosed, I started looking at it myself. Not that I'm electrician or mechanic for that matter.

    At the battery I was getting 12.5v when the car was running, but at the jumper point I got from 13.5 to 15.75v. (oscillated up and down)
    So I tracked the cable from the battery to the engine and I found it under the jumper point on the left side of the engine by the concentrated washer fluid tank. (See picture 1)
    To do this DISCONNECT the battery first.
    The access to this part is not easy but you can take the unit off the car.
    The cable going to the battery showed marks of shorting all around the bolt connecting it to the jumper point bracket, were it had corroded and made bad contact. (See picture 2+4)
    I took the bracket out of the unit and cleaned it with metal brush and greased all nuts&bolts and the bracket. (See picture 3)
    Put the bracket back in the unit and repositioned it in it's housing. Reconnected all the cables and made sure all bolts were done up.
    Started the car and checked the voltage at the battery, and got a 14.4v when running idle and 12.93v key off, constant, no oscillation or very little.

    Hope this helps someone. I know the battery not charging is a common problem, and the solution is not the same for everyone.

    Get the voltmeter out and look at voltage to the battery and voltage to the jumper point, if it's not the same then you most likely have this issue also. Check the cable going from the bottom of the jumper point through the firewall all the way to the battery. (On E36)
    Attached Images
    Last edited by ukfrog; 11-04-2011 at 11:48.

    525e 1976, 2002 1971, 316i 1986, 325i 1992, ?
     
     

  2. The Following 4 Users Say Thank You to ukfrog For This Useful Post:

    e36nickd (18-04-2011),Ferret (11-04-2011),Ronnie (11-04-2011),TheEnd (11-04-2011)

  3. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  4.  
    #2
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    Good work ukfrog,
     
     

  5.  
    #3
    BMW Crazed
    Car Details
    ukfrog's Car Details
    Model of Car:
    528i s
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    saloon
    ukfrog's Avatar
    Join Date
    May 2008
    Location
    South west
    Posts
    130
    Thanks
    0
    Thanked 4 Times in 1 Post
    Just doing my bit...

    525e 1976, 2002 1971, 316i 1986, 325i 1992, ?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts