1993 E36 325 convertible amp help - Page 4

Notices
 

Thread: 1993 E36 325 convertible amp help

Reply to Thread
Page 4 of 4 FirstFirst 1234
Results 31 to 34 of 34
  1.  
    #31
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    The power ratings not a problem mate, the only thing that would affect the amp would be the impedance of the speakers, but i'm guessing their 4ohms? and your using them 1 per channel so it should all be okay. Everything is pointing towards a duff amp
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #32
    BMW Maestro
    Car Details
    spartacus1's Car Details
    Model of Car:
    330i sport
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    spartacus1's Avatar
    Join Date
    Feb 2009
    Location
    preston lancs
    Posts
    773
    Thanks
    8
    Thanked 86 Times in 73 Posts
    god dam it lol o well i tried win some lose some
     
     

  4.  
    #33
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    Atleast all your wirings there, just need to lob in another amp now
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #34
    BMW Maestro
    Car Details
    spartacus1's Car Details
    Model of Car:
    330i sport
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    spartacus1's Avatar
    Join Date
    Feb 2009
    Location
    preston lancs
    Posts
    773
    Thanks
    8
    Thanked 86 Times in 73 Posts
    yea had another head scratch today all wires are fine right place and the earth is in even tried a bigger one. it still comes on split second then cuts off. going t take it out tomorro and connect the rears back up properly and then get a sub with an amp built in . so watch out ill be back hahaha
     
     

Page 4 of 4 FirstFirst 1234
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts