1992 E36 Saloon - ZVM Cental locking module problem.

Notices
 

Thread: 1992 E36 Saloon - ZVM Cental locking module problem.

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. 1992 E36 Saloon - ZVM Cental locking module problem. 
    #1
    BMW Master
    Car Details
    McClobber's Car Details
    Model of Car:
    E46 328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Auto
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    Glasgow
    Posts
    329
    Images
    4
    Thanks
    105
    Thanked 50 Times in 45 Posts
    Ello peepl, I need to change my ZVM module as my CL, Windows and Sunroof are playing up. Done a little bit of searching and found that there are a few versions of this module part numbers ending in 569,100 & 621. Mines is 569 so will any of the other modules work and do the same job?? Any body have any knowledge about this? It would be really appreciated.
    I have raised this issue in the e36 section too without any answers so sorry to any mods if this is rule breaking as such.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    billywhizz1984's Car Details
    Model of Car:
    E36 323i x 3, 325TDS x 1, 320i x 2, 318is x 1
    Year of Manufacture:
    1999 x 2, 1998, 1997 x 2, 1996, 1995
    Transmission Type:
    Manual, Auto, Auto, Manual, Auto, Auto, Manual
    Car Body Type:
    Touring x 4, Convertible x 2, Coupe x 1
    billywhizz1984's Avatar
    Join Date
    Sep 2009
    Location
    North East
    Posts
    2,493
    Images
    4
    Thanks
    165
    Thanked 933 Times in 703 Posts
    You don't say but I presume you've looked into the Comfort Relay issue?

    http://www.bimmerforums.co.uk/forum/...-module-t3138/
     
     

  4. The Following User Says Thank You to billywhizz1984 For This Useful Post:

    McClobber (24-10-2011)

  5.  
    #3
    BMW Master
    Car Details
    McClobber's Car Details
    Model of Car:
    E46 328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Auto
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    Glasgow
    Posts
    329
    Images
    4
    Thanks
    105
    Thanked 50 Times in 45 Posts
    awlrite billy cheers... yeah i checked out the relay a while ago and it was fine. Changed the wires at the boot lid too. I think I will whip the relay out again tomorrow and double check as its easy to get to, just whip of the cover under the glovie then I can see it. I didnt realise this comfort relay messed about with the Central locking... thought it was only the windows and sunroof tbh.
    My problem is more a CL issue now rather than the windows, the windows cut out every now and then but its the CL that goes everyday. I will get back to ya with my results big guy cheers bossman
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    BMW Master
    Car Details
    McClobber's Car Details
    Model of Car:
    E46 328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Auto
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    Glasgow
    Posts
    329
    Images
    4
    Thanks
    105
    Thanked 50 Times in 45 Posts
    Awlritey...got the relay out today for a goosey gander and on close inspection its fine. Tried the CL without the relay in and it still locked (well some of the doors lol).
    Usually I remote CL lock the doors then they instantly bounce back up sometimes. other times when I lock it the nsr will stay open so I have to put the key in the door, open them then dead lock them so they all go down..doing my bristol citys in
     
     

  8.  
    #5
    BMW Guru
    Car Details
    billywhizz1984's Car Details
    Model of Car:
    E36 323i x 3, 325TDS x 1, 320i x 2, 318is x 1
    Year of Manufacture:
    1999 x 2, 1998, 1997 x 2, 1996, 1995
    Transmission Type:
    Manual, Auto, Auto, Manual, Auto, Auto, Manual
    Car Body Type:
    Touring x 4, Convertible x 2, Coupe x 1
    billywhizz1984's Avatar
    Join Date
    Sep 2009
    Location
    North East
    Posts
    2,493
    Images
    4
    Thanks
    165
    Thanked 933 Times in 703 Posts
    Have you had the passenger seat out and had a look at the common earths in the foot well & floor?
     
     

  9. The Following User Says Thank You to billywhizz1984 For This Useful Post:

    McClobber (25-10-2011)

  10.  
    #6
    BMW Master
    Car Details
    McClobber's Car Details
    Model of Car:
    E46 328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Auto
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    Glasgow
    Posts
    329
    Images
    4
    Thanks
    105
    Thanked 50 Times in 45 Posts
    Tbh billy I haven't checked the earth under the seat. I fitted an auto dim mirror few months back and wired it into the reverse signal so I fed the wire around the a pillars and down into the footwell. I checked the earth in the footwell while I was dwn there and it was spot on. I dnt have time tomorro nyt to do this, going out for dinner so it'l b thursday nyt before I get to this. I'll get back ti you and let you kno what is going down mate.
    Cheers
    Aldo
     
     

  11.  
    #7
    BMW Master
    Car Details
    McClobber's Car Details
    Model of Car:
    E46 328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Auto
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    Glasgow
    Posts
    329
    Images
    4
    Thanks
    105
    Thanked 50 Times in 45 Posts
    Well my dinner was cancelled tonyt so straight car i went and whipped out the seat to find this earth.......only to find when the carpet was up that there was no earth under there.
    Only the one at the bulkhead in the footwell.



    I took off the plastic wire covers and the air vent also and nothing. I dont know how to describe them but its like power feeds clips that wer down there. I know they arent the earths because they aint attached to the body...they were clipped onto little studs on the strengthening panel I'll show you a pic



    So I decided to check out the earth at the bulkead and it was ok...I went round it with sandpaper anyways seen as I went that far and then built it all back up. Tried the CL and it worked first time....tried it 5 times and it all worked its supposed too. Happy Days! I'm surprised to say the least . Now I will look out for this every time I try it in the next couple of days, I'm not saying its fixed because this it what my car does...works then it doesnt. Pain in the a**e lol. Motors ae. I will get back in a few days if alls well to keep you in the light.
    Thanks very much
    Aldo
     
     

  12. The Following User Says Thank You to McClobber For This Useful Post:

    billywhizz1984 (29-10-2011)

  13.  
    #8
    BMW Master
    Car Details
    McClobber's Car Details
    Model of Car:
    E46 328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Auto
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    Glasgow
    Posts
    329
    Images
    4
    Thanks
    105
    Thanked 50 Times in 45 Posts
    Awlrite there... alls been well with the CL, untill yesterday and today. Went to open the car with the fob and all doors popped up and then immediatly locked back down...done it 3 times sunday.
    Today I went ti the garage for petrol and locked it but only the OS locked whilst the NS stayed open...tried it twice with the same outcome.
    Duno what to think of this its doing my nut in. Next chance I get I'm gona check out this loom in the boot again but I know this is ok koz Ive already check it three times.
    Aldo
     
     

  14.  
    #9
    BMW Guru
    Car Details
    billywhizz1984's Car Details
    Model of Car:
    E36 323i x 3, 325TDS x 1, 320i x 2, 318is x 1
    Year of Manufacture:
    1999 x 2, 1998, 1997 x 2, 1996, 1995
    Transmission Type:
    Manual, Auto, Auto, Manual, Auto, Auto, Manual
    Car Body Type:
    Touring x 4, Convertible x 2, Coupe x 1
    billywhizz1984's Avatar
    Join Date
    Sep 2009
    Location
    North East
    Posts
    2,493
    Images
    4
    Thanks
    165
    Thanked 933 Times in 703 Posts
    So, in summary

    Boot wiring ok (but will do 3rd check!)
    Earths ok
    Comfort relay OK

    Another option is that one of the front door solenoids is jamming up, causing the system to not "set" fully then it automatically unlocks. Is the action of the door handles & locks on both sides smooth?

    This might also help you understand how the system works...

    http://www.unofficialbmw.com/images/lock.pdf
     
     

  15.  
    #10
    BMW Master
    Car Details
    McClobber's Car Details
    Model of Car:
    E46 328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Auto
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    Glasgow
    Posts
    329
    Images
    4
    Thanks
    105
    Thanked 50 Times in 45 Posts
    So yeah to summarise mate

    Boot loom ok
    Earths ok
    & Comfort Relay ok.

    All door locks & handles work as they should when its working ok... when the NSR stays open and I try to push the pin down its really stiff, so I push it down so it locks then after that it'l b ok for a while.

    The Windows wouldnt work again on the journey to work this morning so locked it (fine), went to work, on journey home the windows worked ok . Wierd man so this is whats making me think the ZVM is o its last legs.

    Where are all the earth points on the saloon..or common ones so I can check them all out.

    See when I press the fob to send the signal to lock the doors...should it also lock the boot at the same time? It doent do this. If I need to open the boot I have to do it with the key so when I go to lock the boot with the key it dead locks everything...then i need to put the key back in the door to unlock it and get back in. nuts

    Something in my head is telling me the boot actuator is gubbed but then why would this not lock the doors when I press the fob?, particullarly the NSR as this is the one most prone to staying open when its being asked to lock...when I dead lock with the key it goes down ok. I thought about changing the NSR actuator too but the OSR sometimes stayed open too in conjunction with the NS...then th NSF had a shot of playing up.

    Would a snuffed boot & nsr actuator cause all my symptoms or am I that unlucky that I have a snuffed ZVM,Boot & NSR Door actuator all at the one time??Plus dodgey earths lol dunno

    driving me potting mate lol
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts