1992 E36 325 coupe - fuel and speedo dials not moving

Notices
 

Thread: 1992 E36 325 coupe - fuel and speedo dials not moving

Reply to Thread
Results 1 to 8 of 8
  1. 1992 E36 325 coupe - fuel and speedo dials not moving 
    #1
    BMW Maestro
    Car Details
    spartacus1's Car Details
    Model of Car:
    330i sport
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    spartacus1's Avatar
    Join Date
    Feb 2009
    Location
    preston lancs
    Posts
    773
    Thanks
    8
    Thanked 86 Times in 73 Posts
    hi there my cousin just bought this car its an e36 325 coupe 1992 he has told me the fuel needle and speed needle not moving. the rev and temp fine .
    ive done the teast and all needles move. ive took out cluster and checked the plugs and wiring for out lose but i dont know in this area what to do. at weekend am going to plug mine in see what happens can justify then if its wiring or cluster. any one ideas please help cheers .

    p.s ive told him to join lol
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Platinum BFuk Member
    Car Details
    wolvesdug's Car Details
    Model of Car:
    325i X3
    Year of Manufacture:
    1992 2004
    Transmission Type:
    Manual
    Car Body Type:
    coupe 4x4
    wolvesdug's Avatar
    Join Date
    Sep 2009
    Location
    shropshire
    Posts
    1,361
    Thanks
    454
    Thanked 783 Times in 688 Posts
    Check the fuses 23,27,31 and 46
     
     

  4.  
    #3
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    Also, the fuel sensors and the speed sensor both signal via the same earth so may be that the 12 pin connector at the rear of the cluster is loose
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Maestro
    Car Details
    spartacus1's Car Details
    Model of Car:
    330i sport
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    spartacus1's Avatar
    Join Date
    Feb 2009
    Location
    preston lancs
    Posts
    773
    Thanks
    8
    Thanked 86 Times in 73 Posts
    where is the fuel sensor located
     
     

  7.  
    #5
    Platinum BFuk Member
    Car Details
    wolvesdug's Car Details
    Model of Car:
    325i X3
    Year of Manufacture:
    1992 2004
    Transmission Type:
    Manual
    Car Body Type:
    coupe 4x4
    wolvesdug's Avatar
    Join Date
    Sep 2009
    Location
    shropshire
    Posts
    1,361
    Thanks
    454
    Thanked 783 Times in 688 Posts
    Have you got it working? Any blown fuses? the fuel level sensor is in the fuel tank. Lift the back seat up.


    I had this issue and it turned out to be the rear brake lights. The fuses are shared around different things.
     
     

  8.  
    #6
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    Fuel senders are under the rear seats
     
     

  9.  
    #7
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    Check the cables that run into the boot, someone said on another thread their dials wern't working and it turned out to be coroded wires going from the body into the bootlid.
     
     

  10.  
    #8
    BMW Maestro
    Car Details
    spartacus1's Car Details
    Model of Car:
    330i sport
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    spartacus1's Avatar
    Join Date
    Feb 2009
    Location
    preston lancs
    Posts
    773
    Thanks
    8
    Thanked 86 Times in 73 Posts
    no still no joy checked fuses and are ok . doing my dam head in wondering when i run out of fuel and driving like miss daisy lol .. trying a mates cluster panel on it at weekend . i did the needle test thing and they all move fine. will check them wires going to the boot also . see how it goes cheers
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts