1992 E36 - 320i - Electrical Issues

Notices
 

Thread: 1992 E36 - 320i - Electrical Issues

Reply to Thread
Results 1 to 2 of 2
  1. 1992 E36 - 320i - Electrical Issues 
    #1
    BMW Fanatic
    Car Details
    Keksiboi's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    1991
    Transmission Type:
    Manual
    Car Body Type:
    Saloon
    Keksiboi's Avatar
    Join Date
    Mar 2011
    Location
    Brisbane, Queensland, Australia
    Posts
    73
    Thanks
    35
    Thanked 15 Times in 11 Posts
    Hey Guys.
    My good ol' 320i has been giving me a really irritating issue lately.
    I have no idea what is causing it, so maybe you have
    Sometimes when starting, Click ignition to #1, Then #2, perfectly fine, electrics seem fine, but once i Turn it to #3 (Start) it shuts off, Leaving no 12v Power in the car, even if i take the key out and turn it to #2, Nothing.
    My only remedy currently is un-bolting my battery, letting it drain, then re-attaching it (Always Remedies the issue.)
    Thanks in advance.

     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    joylove's Car Details
    Model of Car:
    328
    Year of Manufacture:
    1998
    Transmission Type:
    Manual
    Car Body Type:
    cabrio

    Join Date
    Sep 2010
    Location
    UK
    Posts
    1,500
    Thanks
    108
    Thanked 467 Times in 367 Posts
    Could be a dying ignition switch, that's the first thing I'd change.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts