1990 E34 535i - Central Locking

Notices
 

Thread: 1990 E34 535i - Central Locking

Reply to Thread
Results 1 to 10 of 10
  1. 1990 E34 535i - Central Locking 
    #1
    Bimmer Fan
    Car Details
    BMWSCOTTIE's Car Details
    Model of Car:
    535i SPORT AUTO
    Year of Manufacture:
    1990
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    SALOON

    Join Date
    Sep 2009
    Location
    Perth
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hey guys,

    I have a 1990 535i and I am having problems with the central locking. Can anyone help me find the module that apparently controls this?

    I'm not sure where to look and what i'm looking for.

    Thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    What kind of problems?
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    BMWSCOTTIE's Car Details
    Model of Car:
    535i SPORT AUTO
    Year of Manufacture:
    1990
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    SALOON

    Join Date
    Sep 2009
    Location
    Perth
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Where do I start?

    1. Remote locks car, doesn't open it
    2. Drivers door lock will not operate at all, unless unlinked from central locking when removing the motor, wont even open via emergency method!
    3. When using passenger door lock, it opens and locks immediately.

    I've replaced motor in drivers door, cleaned all contacts, plugs and locks but still no change.

    NB When I removed the motor from drivers door the doors opened through passenger door and DID NOT lock immediately but remote still didn't open car.

    I've tried everything I know and Its been suggested that theres a module that controls all of this, hence why I'm at this stage.

    PLEASE HELP ME!!!!!!!!!!
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    First thing to look at is the wiring loom the connects the boot lid to the body. Peel back the rubber to see if there are no broken or frayed wires shorting. Then you can move on to the module.
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    BMWSCOTTIE's Car Details
    Model of Car:
    535i SPORT AUTO
    Year of Manufacture:
    1990
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    SALOON

    Join Date
    Sep 2009
    Location
    Perth
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok Great Thanks, its in getting an exhaust tomorrow AM so I'll look tomorrow PM. Thanks, your help is very much appreciated :-)
     
     

  8.  
    #6
    Bimmer Fan
    Car Details
    BMWSCOTTIE's Car Details
    Model of Car:
    535i SPORT AUTO
    Year of Manufacture:
    1990
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    SALOON

    Join Date
    Sep 2009
    Location
    Perth
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hey there, all the wiring from the car into the boot lid appears fine with no breaks etc although I dont have a multimeter to confirm this.
     
     

  9.  
    #7
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Ok, under the rear seat you will find there is supplemental fuse box that contains relays and the general module. These control the body electrics of the car, so see if you can locate and isolate the relays.
     
     

  10.  
    #8
    Bimmer Fan
    Car Details
    BMWSCOTTIE's Car Details
    Model of Car:
    535i SPORT AUTO
    Year of Manufacture:
    1990
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    SALOON

    Join Date
    Sep 2009
    Location
    Perth
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I found them but what do I need to do? It seems a bit of a muddle in there. What might I be looking for cause as far as i'm concerned its just a bunch of little black boxes etc?

    Cheers
     
     

  11.  
    #9
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Just check to see if they are plugged in. After that, try eliminating each relay for functionality.
     
     

  12.  
    #10
    Bimmer Fan
    Car Details
    BMWSCOTTIE's Car Details
    Model of Car:
    535i SPORT AUTO
    Year of Manufacture:
    1990
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    SALOON

    Join Date
    Sep 2009
    Location
    Perth
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok i'll do that, thanks. PS I'll be in touch
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts