2001 e46 abs sensor fault

Notices
 

Thread: 2001 e46 abs sensor fault

Reply to Thread
Results 1 to 9 of 9
  1. 2001 e46 abs sensor fault 
    #1
    Bimmer Fan
    Car Details
    2001_3seriescoupe's Car Details
    Model of Car:
    320 ci
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    May 2009
    Location
    belfast
    Posts
    19
    Thanks
    0
    Thanked 1 Time in 1 Post
    Heyy I needa change my front left abs sensor,, anyone got any tips???
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Be very careful with the Allen bolt that holds the sensor on, as they are common for snapping as they have usually been undisturbed for some time, you should try liberally soaking the bolt with some good penetrative spray, and seeing as the sensor is knackered already then a gas hammer doesn't go amiss.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    2001_3seriescoupe's Car Details
    Model of Car:
    320 ci
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    May 2009
    Location
    belfast
    Posts
    19
    Thanks
    0
    Thanked 1 Time in 1 Post
    Wish I had of waited to see your reply, cuz the bolt just snapped on me there!! Any ideas on How I can I get it out???
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Quote Originally Posted by 2001_3seriescoupe View Post
    Wish I had of waited to see your reply, cuz the bolt just snapped on me there!! Any ideas on How I can I get it out???
    You will be best centre punching the bolt as central as possible and then drilling the bolt out enough so you can use a easy out OR keep going up the drill sizes until you can carefully use a Tap to get the old bits of bolt out.

    http://www.machinemart.co.uk/shop/ca...tud-extractors

    A gas torch or oxy/acetylene is very handy if you are going down the screw extractor route.
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    2001_3seriescoupe's Car Details
    Model of Car:
    320 ci
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    May 2009
    Location
    belfast
    Posts
    19
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks for the advise :-)
     
     

  8.  
    #6
    BMW Crazed
    Car Details
    Mark_F's Car Details
    Model of Car:
    323/5
    Year of Manufacture:
    E36
    Transmission Type:
    Manual
    Car Body Type:
    Coupé

    Join Date
    Mar 2010
    Location
    Home
    Posts
    180
    Thanks
    37
    Thanked 32 Times in 27 Posts
    In contrast, my bolt came out fine but the sensor itself was wedged in solid. Destroyed a perfectly good sensor trying to remove it. :(
     
     

  9. 2001 abs sensor 
    #7
    Bimmer Fan
    Car Details
    simo.dookit's Car Details
    Model of Car:
    E46 330
    Year of Manufacture:
    2004
    Transmission Type:
    Auto
    Car Body Type:
    Convertible

    Join Date
    Aug 2010
    Location
    Morecambe
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi Mark,

    I've got the same problem bolt came out no problem, can't get the sensor out.

    Have soaked it in loose oil and have snapped the end offtrying to lever it.

    Any suggestions to get the rest of it out???
     
     

  10.  
    #8
    BMW Crazed
    Car Details
    shrekster's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2002
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Apr 2010
    Location
    Glasgow
    Posts
    155
    Thanks
    1
    Thanked 72 Times in 59 Posts
    Quote Originally Posted by 2001_3seriescoupe View Post
    Wish I had of waited to see your reply, cuz the bolt just snapped on me there!! Any ideas on How I can I get it out???
    If the sensor is still in place use a pair of mole grips and just wrench it out, you may be lucky and still have a little of the allen bolt showing you can get a grip of. Use plenty of penetrating fluid and possibly a blow torch if you have one, otherwise as already suggested you'll have to drill it out.
    If when you are finished the ABS light stays on follow this procedure- open the drivers door, turn the ignition key to the second position and wait for the light to go out, it can take up to 40 seconds.
    Best of luck,

    Shrekster.
     
     

  11.  
    #9
    Bimmer Fan
    Car Details
    terrymatthews's Car Details
    Model of Car:
    320d se
    Year of Manufacture:
    2002
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Aug 2010
    Location
    northampton
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi my name is Terry and i am new to forums altogether. I dont even know if i am writing this post in the right place lol but hopefully one of you guys can point me in the right direction lol.

    I have an e46 320d se saloon 2002 plate and i have an issue with power. Basically, when you change gear from 1st to second at high revs the turbo seems to stall for a while. If you take your foot off and then put it back on the accelerator, it goes back to normal.

    Does anyone have any ideas what this could be? Has anyone had this issue before?

    It would be great if i could get to the bottom of this as the rest of the car is in mint condition.

    Thanks

    Terry
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts