1995 E36 318is- abs problem

Notices
 

Thread: 1995 E36 318is- abs problem

Reply to Thread
Results 1 to 5 of 5
  1. 1995 E36 318is- abs problem 
    #1
    Bimmer Fan
    Car Details
    stnmartin's Car Details
    Model of Car:
    318is
    Year of Manufacture:
    1995
    Transmission Type:
    automatic
    Car Body Type:
    coupe
    stnmartin's Avatar
    Join Date
    Jun 2012
    Location
    scotland
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi all! i have an e36 318is coupe, 3 months ago my car was on MOT test and after a few hours thee abs light comes on and i have it still.....
    from that time i replaced the sensors, cleaned the wheel speed sensors, replaced the abs ecu, replaced 3 times the abs relays (i use all the time second hand relays, red and grey colour), replaced the abs pump, my car get before the MOT new ball joints, lower arms, struts, brake discs-pads. but the light is stays on... yesterday i noticed the front brake wear sensor is broken and fallin out from its place, can this be my problem??? or bubbles in the brake lines somewhere??? or what the hell???!!!! anybody can help me out from this gap??
    many thanks!
    martin
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,981
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    Have you checked for fault codes?
    That should direct you to the problem without changing parts and hoping.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    stnmartin's Car Details
    Model of Car:
    318is
    Year of Manufacture:
    1995
    Transmission Type:
    automatic
    Car Body Type:
    coupe
    stnmartin's Avatar
    Join Date
    Jun 2012
    Location
    scotland
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    can i do the fault code reading my self, or i need to go to a dealer or garage? thank you.
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,981
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    You should be able to do it with INPA, but you'll probably need an "ADS" interface from ebay.

    Search inpa ads on ebay and some should turn up.
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    stnmartin's Car Details
    Model of Car:
    318is
    Year of Manufacture:
    1995
    Transmission Type:
    automatic
    Car Body Type:
    coupe
    stnmartin's Avatar
    Join Date
    Jun 2012
    Location
    scotland
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hi there! thank you for your advice!!! i call my friend who have this fault code reader, we done it and it says it is the sensor.... i'm so surprised cause i have new sensors before MOT (a few months ago) and we start to chek the sensors all around the car, after a while i'm noticed a relased plastic wheel arch cover at the right front wheel. the wires for the abs sensor connector runs behind this, so we take off the full plastic piece and we see two separated piece of the wireing, the plastic while moving cuts my abs sensor wire. i'm re-connect them temporary till i get the new sensor and they starts to work i think nobody cant imagine that....
    anyway THANK YOU for the tips and advice!! have a nice day!
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts