Rear winscreen wiper issues on an 2005 e61 M Sport

Notices
 

Thread: Rear winscreen wiper issues on an 2005 e61 M Sport

Reply to Thread
Results 1 to 5 of 5
  1. Rear winscreen wiper issues on an 2005 e61 M Sport 
    #1
    Bimmer Fan
    Car Details
    530d M Sport's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Sep 2013
    Location
    Somerset
    Posts
    15
    Thanks
    4
    Thanked 1 Time in 1 Post
    Hey guys!
    I have recently purchased an E61 530d M Sport and have got an issue with the rear windscreen wiper.
    When i push back on the stalk it will wipe but after five or six times of wiping it will stop working for a while then come back to life. Also even with the stalk back it will not stay on at all which means i have to pull the stalk forward then back again to wipe. When the wiper stope working so does the window cleaner/sprayer.

    The only thing i have tried is to open the glass on the boot and clean the contact points but am stuck as to where to go next.

    May i point out this is my first beamer for many years but other than this slight issue I am over the moon with it!

    Any help will be gratefully received.

    Adam
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Maestro
    Car Details
    Vista's Car Details
    Model of Car:
    E61 535D M-Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Auto
    Car Body Type:
    Touring
    Vista's Avatar
    Join Date
    Jan 2010
    Location
    South West
    Posts
    781
    Thanks
    30
    Thanked 300 Times in 261 Posts
    The rear screen wiper is only an intermittent wipe, it doesn't stay on constantly except when you're holding the stalk fully back to use the rear screen wash or when you're in reverse with it switched on
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    530d M Sport's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Sep 2013
    Location
    Somerset
    Posts
    15
    Thanks
    4
    Thanked 1 Time in 1 Post
    It doesn't actually work intermittently at all!
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    530d M Sport's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Sep 2013
    Location
    Somerset
    Posts
    15
    Thanks
    4
    Thanked 1 Time in 1 Post
    Incase anyone is interested I remedied this problem without help from anyone! I replaced the stalk and this completely solved the problem. The stalk was filthy inside with hair and debris, and the new one does look much better! At a cost of £78.50 it should do!!!
     
     

  7.  
    #5
    BMW Maestro
    Car Details
    Vista's Car Details
    Model of Car:
    E61 535D M-Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Auto
    Car Body Type:
    Touring
    Vista's Avatar
    Join Date
    Jan 2010
    Location
    South West
    Posts
    781
    Thanks
    30
    Thanked 300 Times in 261 Posts
    Glad you got it sorted. That's not an issue I've ever heard of before.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts