Hi All,

I am new to the forum, although not new to the BMW brand. I belong to the BMW FANATICS club and BMW Club in South Africa. I own a few BMW's models. 76'BMW530 MLE, i recently completed a full nut and bolt restoration on this car. 67'2002, 69 1600, 70' 2002 which are all waiting full restorations and another 530MLE to be built into a Race replica of the Soth Africa Salora TV 530MLE race car. I own a 2008 335i and my latest aquisition is a Laguna Green 91' 850Ci UK version (M70).

I am sure I will enjoy the site, just as much as I enjoy the local Fanatics forum where we are all a close knit family enjoying True Driving Joy!

I am also seeking advice at the same time, and this may need to be reposted.

Since purchasing the 850Ci is have started restoring and repairing as much as possible getting the car back to the beauty it should be. Engine covers, clips, OEM radio and amp, wheel badges etc etc.

I am however battlying with the engine and perhaps someone here can assist, I have also posted the same on the 8coupe site and with Wuffer too.

Below is a list of the problem as its developed in order of occurence and the order of parts replacment. Since not many 850 in SA my base of technical assistance in SA is small. I am technicaly minded and have a fully equipped workshop, so will try any advise possible.

1. Car drove, however had a misfire.
2. Removed manifolds and tappet covers for powder-coating.Had new HT Leads made using the 2 old cam sensors.
3. Car started but smoked ridicoulous amounts of white smoke.
4. Replaced both vacuum pipes and valves on manifolds and seals, then the 2 tappet cover gaskets. New 40W oil and oil filter.
5. Engine fuel pipes replaced.
6. Car refuses to start but cranks.
7. Find 80amp fuses in boot from the battery are cracked and replace. Car starts and only idles. Refuses to rev. No smoke
8. Replace both crank sensors.Car starts, revs very slowly and no power, also no idle. NO smoke
9. Replace both fuel pumps, car starts, idles and revs. However white smoke is back, also sump pressure too high. Oil trying to come out at dipstick and pressure build-up at oil filler.

All 12 piston compression is 8.0 and above.


Anybody know why the smoke?? and pressure build up?

my email is luis@carmalcorp.com

Thanks Guys