Newbie with an E39 problem

Notices
 

Thread: Newbie with an E39 problem

Reply to Thread
Results 1 to 9 of 9
  1. Newbie with an E39 problem 
    #1
    Bimmer Fan
    Car Details
    brookybungle's Car Details
    Model of Car:
    E39
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Feb 2012
    Location
    south wales
    Posts
    0
    Images
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hiya, I have an E39 1999 2.0l saloon auto. A couple of months ago, the ASC light came on, then another one lit up which looks like a circle/arrow (?), now the fuel gague is totally inaccurate, it shows a full tank when i know there is less than 1/2 in there, the odometer doesn't work and neither does the speedo or MPG gague. Also have a problem with the wiper speeds since all this started. I have been told that it could be the speed sensors or ABS sensors. Has anyone else come across this? It's getting to the point where I'm seriously concidering getting rid of it and getting a 4x4. ANy advice would be great.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Fanatic
    Car Details
    pauldf1971's Car Details
    Model of Car:
    318 ci se
    Year of Manufacture:
    2002
    Transmission Type:
    manaul
    Car Body Type:
    coupe
    pauldf1971's Avatar
    Join Date
    Feb 2012
    Location
    glasgow
    Posts
    90
    Thanks
    6
    Thanked 17 Times in 16 Posts
    i dont know about the e39 but my e46 had the same issues when i was checking for a faulty sensor i swapped the rears over and then my speedo etc did the same,i replaced the near side rear abs/vehicle speed sensor and problem solved.it would help if you can plug into the diagnostic port to see what fault code it shows as you could have more than one faulty sensor or other issues
     
     

  4. The Following User Says Thank You to pauldf1971 For This Useful Post:

    brookybungle (06-02-2012)

  5.  
    #3
    Bimmer Fan
    Car Details
    brookybungle's Car Details
    Model of Car:
    E39
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Feb 2012
    Location
    south wales
    Posts
    0
    Images
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I have plugged it in at 2 different local garages ( not BMW tho ) and apparently nothing comes up!
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    BMW Master
    Car Details
    shiku84's Car Details
    Model of Car:
    E39 530D Platinium
    Year of Manufacture:
    2003
    Transmission Type:
    AUTO
    Car Body Type:
    TOURING Fully loaded

    Join Date
    Jul 2009
    Location
    London/Bologna
    Posts
    450
    Thanks
    9
    Thanked 131 Times in 124 Posts
    It sounds like the ABS sensors have packed up. They serve as ASC and ABS and traction control. The cost about 70 pound a piece. Its weird that nothing comes up to be frank when u do the check but i have had a similar issue on my x E36 323I.
    My BMW history= E36 318IS, 323I,Mini Cooper, E46 320 D SE and now E39 530D. awesome
     
     

  8.  
    #5
    BMW Fanatic
    Car Details
    pauldf1971's Car Details
    Model of Car:
    318 ci se
    Year of Manufacture:
    2002
    Transmission Type:
    manaul
    Car Body Type:
    coupe
    pauldf1971's Avatar
    Join Date
    Feb 2012
    Location
    glasgow
    Posts
    90
    Thanks
    6
    Thanked 17 Times in 16 Posts
    i paid £18 for mines on my e46(new)
     
     

  9.  
    #6
    BMW Master
    Car Details
    shiku84's Car Details
    Model of Car:
    E39 530D Platinium
    Year of Manufacture:
    2003
    Transmission Type:
    AUTO
    Car Body Type:
    TOURING Fully loaded

    Join Date
    Jul 2009
    Location
    London/Bologna
    Posts
    450
    Thanks
    9
    Thanked 131 Times in 124 Posts
    Quote Originally Posted by pauldf1971 View Post
    i paid £18 for mines on my e46(new)
    I paid 70 quid of BMW dealer.
    My BMW history= E36 318IS, 323I,Mini Cooper, E46 320 D SE and now E39 530D. awesome
     
     

  10.  
    #7
    BMW Master
    Car Details
    755munich's Car Details
    Model of Car:
    728i/540i/525iiT
    Year of Manufacture:
    '98/'94/'94
    Transmission Type:
    Both
    Car Body Type:
    Saloon & Touring

    Join Date
    Oct 2011
    Location
    Kent
    Posts
    312
    Thanks
    12
    Thanked 97 Times in 86 Posts
    It could be the ignition switch. Failure gives all sorts of weird problems like you are experiencing and there won't be any codes logged because it doesn't contain any electronics-only electrical on/off contacts.

    Common problem.
     
     

  11.  
    #8
    Bimmer Fan
    Car Details
    brookybungle's Car Details
    Model of Car:
    E39
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Feb 2012
    Location
    south wales
    Posts
    0
    Images
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    thanks to all who responded, i think i'll replace the leads then if all fails i'll try the ignition switch.
     
     

  12.  
    #9
    BMW Guru
    Car Details
    Spirit's Car Details
    Model of Car:
    e36 323i se saloon
    Year of Manufacture:
    1998
    Transmission Type:
    manual
    Car Body Type:
    saloon
    Spirit's Avatar
    Join Date
    Sep 2010
    Location
    kings lynn-norfolk
    Posts
    4,167
    Thanks
    4,354
    Thanked 2,936 Times in 2,212 Posts
    Hello and welcome to the forum

    Andy
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts