Help required for a 2012 plate Z4 owner

Notices
 

Thread: Help required for a 2012 plate Z4 owner

Reply to Thread
Results 1 to 3 of 3
  1. Help required for a 2012 plate Z4 owner 
    #1
    Bimmer Fan
    Car Details
    ozdog2012's Car Details
    Model of Car:
    Z4
    Year of Manufacture:
    2012
    Transmission Type:
    Manual
    Car Body Type:
    Roadster

    Join Date
    Aug 2012
    Location
    southampton
    Posts
    0
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi
    I am new to this forum and so i apologise if I have posted this in the incorrect place, but I am desperately seeking answers/thoughts on a problem I'm having from other z4 owners. Apologies if my explanation isnt very techy, I'm a girl and it doesnt come naturally!
    I bought a 2012 plate Z4 a few months ago and since I have had it, its been making quite a loud ticking noise from under the bonnet. So much so, the only way to not hear it is to put the radio on or the window down.
    This only happens as low speeds, although this could be because the road noise drowns it out when it goes faster.
    It doesnt seem to matter if the engine is cold or warm and it usually happens when your foot is on the accelerator.
    I have been told by a BMW franchise that it is a common compliant that the manufacturers warned them they may get complaints about. Apparently its something to do with the fuel injection on the new 28i's and the fact that its a Z4 you can hear it more than most cars because of the layout of Z4 in relation to where the fuel injectors are.

    Are they fobbing me off with this, or is it true? Are there any other 2012 plate 28i owners who are experiencing the same?

    Massive Thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Fanatic
    Car Details
    BMWNICK's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Jul 2011
    Location
    London
    Posts
    36
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Does this happen with any other model (35i)? I think the 28i has a 4cyl engine as in the 20i, which would lead me to believe that the injectors would be in the same place and that model would also experience the same problem. Is there any mention of this on other forums?
    I can't help much more as I have a 325ci, but maybe this helps your search a bit more.
     
     

  4.  
    #3
    Moderator
    Car Details
    matthew_henson's Car Details
    Model of Car:
    E61 525d Touring
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Touring/Estate
    matthew_henson's Avatar
    Join Date
    Mar 2011
    Location
    Forest Of Dean
    Posts
    4,210
    Thanks
    904
    Thanked 1,412 Times in 1,223 Posts
    With a 2012 model I would be expect BMW to resolve it ASAP, I would also be getting them to look at valve tappets and the timing chain.

    Either way make them fix it!
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts