Hello and Heeeeellllppppppppppp !!

Notices
 

Thread: Hello and Heeeeellllppppppppppp !!

Closed Thread
Results 1 to 2 of 2
  1. Hello and Heeeeellllppppppppppp !! 
    #1
    Bimmer Fan
    Car Details
    Jims101's Car Details
    Model of Car:
    z3
    Year of Manufacture:
    1997
    Transmission Type:
    manual
    Car Body Type:
    convertible

    Join Date
    Mar 2012
    Location
    Essex
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi BMW forum,

    Im James and am at my wits end with my Z3 2.8 1997.

    Its not starting its turning over no problem but not igniting. I will tell you the problems.

    1. Under load it would occasionally lose power but regain it quick as if i had taken the foot off accelerator. This happened very recently and about three times. on the journey home it stalled but started ok.

    2. I was told it could be throttle position sensor. so replaced this.

    3. Next time i started i noticed it was a bit hesitant in starting, drove to the petrol station hoping things would be ok but its was the same.

    4. Came home parked up, now it wont start. Had a mecahnic look at it on a computer diagnossis machine and it couldnt log in to the car.

    5. my friend asked if i put diesel in ?? Now im worried i did, but this wouldnt of been the cause for the loss in power in the first instance.

    Please please help im starting to lose interest in the car. oh and by the way not too technical please lol im a mechanical numpty.

    Thanks
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    SlowTech's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    SlowTech's Avatar
    Join Date
    Mar 2009
    Location
    North West
    Posts
    7,043
    Thanks
    3,720
    Thanked 3,799 Times in 3,107 Posts
    Hi James and welcome to the forums

    Please post your issue in the correct technical forum, BMW Z Series Forum - Technical Talk on the BMW Z cars Z1, Z3, Z4, Z8 and Z9,
    with a suitable thread title eg. 1997 Z3 2.8 - Will not start.
    that way members will immediately be able to identify the issue and hopefully assist you, good luck in finding a quick solution
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts