2000 E39 523i Tourer Heater Blower not working

Notices
 

Thread: 2000 E39 523i Tourer Heater Blower not working

Reply to Thread
Results 1 to 2 of 2
  1. 2000 E39 523i Tourer Heater Blower not working 
    #1
    Bimmer Fan
    Car Details
    EGNP's Car Details
    Model of Car:
    523i
    Year of Manufacture:
    2000
    Transmission Type:
    Automatic
    Car Body Type:
    Touring/Estate

    Join Date
    Oct 2013
    Location
    UK
    Posts
    0
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi all
    Just joined and this is my first post, so I hope I'm doing it correctly. Apologies if I get it wrong.
    The heater blower has stopped working despite the speed indicator display moving up and down on the + and - button.
    Have checked all the fuses I can find, but I can't find fuse number 76 marked heater blower in the hand book.
    Anyone with any ideas?
    Thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    EGNP's Car Details
    Model of Car:
    523i
    Year of Manufacture:
    2000
    Transmission Type:
    Automatic
    Car Body Type:
    Touring/Estate

    Join Date
    Oct 2013
    Location
    UK
    Posts
    0
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Found the missing fuse and its ok.
    Could it be the hedgehog? Whatever or wherever it is?
    Any help would be greatly appreciated
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts