2005 E60 530d car does not accelerate

Notices
 

Thread: 2005 E60 530d car does not accelerate

Reply to Thread
Results 1 to 5 of 5
  1. 2005 E60 530d car does not accelerate 
    #1
    Bimmer Fan
    Car Details
    raj9999's Car Details
    Model of Car:
    530D
    Year of Manufacture:
    2005
    Transmission Type:
    AUTO
    Car Body Type:
    SALOON

    Join Date
    May 2008
    Location
    London
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi all,

    A few weeks ago, I was driving along the motorway and noticed although I was putting my foot down, the car was not accelerating as it should. Eventually when I got off the motorway, and tried to accelerate having stopped at traffic lights, the car was not picking up speed. I pulled over, put the car in neutral and put my foot down and the rev counter responded accordingly. To cut a long story short, the garage replaced the Diesel Particulate filter. The cars been fine a for a couple of weeks, but now the same symptoms have reappeared. Has anyone had this issue, if so what was the resolution?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Do you also have problems starting? If so, then it could be down to the high pressure pump.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    raj9999's Car Details
    Model of Car:
    530D
    Year of Manufacture:
    2005
    Transmission Type:
    AUTO
    Car Body Type:
    SALOON

    Join Date
    May 2008
    Location
    London
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Starting's not an issue. I took it back to the garage on Friday, they diagnosed the issue as the particle filter again. They reset the error and the car was fin for around 10 mins but then the same issue. The garage said they will need to contact BMW with the error codes and will let me know when they have any info...so for now cars in the drive and unusable.
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6. Same problem 
    #4
    Bimmer Fan
    Car Details
    Sharaz's Car Details
    Model of Car:
    530D
    Year of Manufacture:
    2004
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    May 2010
    Location
    London
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Did you get any further with this, as I have the same problem, it revs ok, but no torque, I am very close to changing the DPF anyhow, so maybe that sorts the problem??
     
     

  7.  
    #5
    Authorised Bimmerforums UK Vendor
    Car Details
    bwchiptune's Car Details
    Model of Car:
    x5
    Year of Manufacture:
    2002
    Transmission Type:
    auto
    Car Body Type:
    estate
    bwchiptune's Avatar
    Join Date
    Jan 2010
    Location
    Hayes west london UB3 1BB
    Posts
    2,687
    Thanks
    52
    Thanked 277 Times in 244 Posts
    these fillters cost £1200ish form bmw,what out if you change the fillter as it my have another problem causing the filter to block up!!!!

    you can remove them complety from the car and have the dpf removed from the ecu' sofware as well
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts