E92 2007 325i se heaters blowing only cold

Notices
 

Thread: E92 2007 325i se heaters blowing only cold

Reply to Thread
Results 1 to 3 of 3
  1. E92 2007 325i se heaters blowing only cold 
    #1
    Bimmer Fan
    Car Details
    Joycey13's Car Details
    Model of Car:
    325i se
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2016
    Location
    Newcastle
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    New to the whole forum thing. I have tried to have a search so apologies if I'am repeating.

    I have 2007 e92 325i se and the heaters are only giving out cold air. It doesn't matter what temp it's set to still freezing. Hot cold dial set to red still freezing cold.
    When the car is idol the temp gauge goes up and it blows warmish air but once the car is moving the temp gauge drops and blows cold air again. I have replaced the thermostat and anti freeze but still no joy. Engine is getting up to temp all pipes etc hot just not the bloody blowers. Any help much appreciated
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    St34lth's Car Details
    Model of Car:
    E36
    Year of Manufacture:
    1993
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Apr 2013
    Location
    Hereford
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Have you checked to make sure that the heater matrix hasn't been bypassed by a previous owner?
    If it's cracked/leaking, rather than the tedious job of dash removal etc. The previous owner may have just bypassed and looped over the 2 pipes going into to the dash area...
    Hope that helps, its worth a look.


    Sent from my iPhone using Tapatalk
     
     

  4.  
    #3
    BMW Fanatic
    Car Details
    p4ddy.b's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1999 (The year of the lemon)
    Transmission Type:
    manual M43
    Car Body Type:
    saloon
    p4ddy.b's Avatar
    Join Date
    Jan 2017
    Location
    southampton
    Posts
    89
    Thanks
    26
    Thanked 6 Times in 6 Posts
    Well you have just highlighted another common fault with these and the e90 it seems. I just googled your problem and found a whole thread on it including this diy fix. I hope this helps? http://www.e90post.com/forums/attach...1&d=1480619476
    1999 318i with crumpled bonnet
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts