E60 2005 Airbag fault error code 93D7

Notices
 

Thread: E60 2005 Airbag fault error code 93D7

Reply to Thread
Results 1 to 3 of 3
  1. E60 2005 Airbag fault error code 93D7 
    #1
    Bimmer Fan
    Car Details
    albert286's Car Details
    Model of Car:
    E60 M5
    Year of Manufacture:
    2005
    Transmission Type:
    SMG
    Car Body Type:
    Saloon

    Join Date
    Jul 2011
    Location
    Newbury, UK
    Posts
    18
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Hi

    Anybody had the fault code 93D7 on the airbag system on a 2005 E60? INPA brings up this code and also in the stored memory it has stored C200, internal acceleration meter x. Cleared codes but comes straight back on again. Possible fault with the central module? Any ideas would be appreciated.

    Many thanks in advance!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Dr of BMW
    Car Details
    kwempe's Car Details
    Model of Car:
    530d e60
    Year of Manufacture:
    2004
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    kwempe's Avatar
    Join Date
    Oct 2010
    Location
    Cambridge, uk
    Posts
    1,306
    Thanks
    108
    Thanked 495 Times in 391 Posts
    If it has appeared for no apparant reason I would check the plugs under both the front seats before going too much further.....don't suppose you have moved the seat further than normal or hoovered under them have you? Has anybody fitted upgraded seats? Also has it brought a dashboard warning indicator too? (CEL)
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    albert286's Car Details
    Model of Car:
    E60 M5
    Year of Manufacture:
    2005
    Transmission Type:
    SMG
    Car Body Type:
    Saloon

    Join Date
    Jul 2011
    Location
    Newbury, UK
    Posts
    18
    Thanks
    0
    Thanked 2 Times in 2 Posts
    It belongs to a friend and literally had 5 mins to plug INPA and read codes, having a proper look on Thursday. It has the usual Airbag warning on the dash. Also has a rear suspension fault but that's probably a split hose by the pump as per. Will check plugs and clean on thursday. I was hoping that will most things somebody was going to say 'It's ..... needs replacing!'
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts